• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSF Hello World program not working  RSS feed

 
won-ki lee
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My code are:

web.xml


HelloBean.java


index.xhtml


When I press run in netbeans nothing is displayed. I expect the string "Hello Bean!".

Help


 
won-ki lee
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got it working guys.

When creating new web application project, in the wizard check JSF and under JSF Configuration check 'Registered Library'. Previously I checked 'Server Library'.

After that Hello World Web app worked as expected.
 
Pete Letkeman
Ranch Foreman
Posts: 906
26
Android Chrome IntelliJ IDE Java MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to CodeRanch Won-ki lee.

I hope that you find everyone helpful, welcoming and knowledgeable. There are some members of this community who are very well versed in Java and Java related technologies so feel free to stop by and ask questions when you need help.
Or stop by to give some help if you are in the mood. I've found that in answering questions I've become more knowledgeable in that subject area as I'm forced to really think about what each line of code is doing and why.

won-ki lee wrote:I got it working guys.

That's great news. It's always rewarding when one is able to fix a problem that they've been dealing with for a number of hours.
 
won-ki lee
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
For your information here's the screenshot



Have to check Registered Libraries.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!