This week's book giveaway is in the Performance forum.
We're giving away four copies of The Java Performance Companion and have Charlie Hunt, Monica Beckwith, Poonam Parhar, & Bengt Rutisson on-line!
See this thread for details.
Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Deploying EAR file in weblogic8.1

 
Bansal Vinay
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have deployed the application using weblogic 7.1 successfully and is running but when i deployed the application in weblogic 8.1 and entered the url http://localhost:7001/home.htm in the browser i got the following error. Is it a version compatibility problem. ?


Error 404--Not Found
From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
10.4.5 404 Not Found
The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.


Steps that i have followed for deployment are :


1. Start the server

2. Opened the server console

3. Created a connection pool with the following properties
Name->demoPool
URL->jdbc dbc:auction
Driver Classname->sun.jdbc.odbc.JdbcOdbcDriver
Properties->user = auction
password = auction

4. Created a datasource with name auctionDataSource and with the following properties
Name->auctionDataSource
JNDI Name->auctionDataSource
Pool Name->demoPool

5. Copied ESaleE.ear(My project ear file) file, which is successfully deployed, in the applications folder of the server

6. Copied the JSP and Html files into the domain's DefaultWebApp folder

7. In the explorer typed the following address "http://localhost:7001/home.htm"
 
Carol Enderlin
drifter
Ranch Hand
Posts: 1364
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you try this, where it's not acting like a default web app? http://localhost:7001/DefaultWebApp/home.htm

(You can also look at the Context Root in the console.)

7.1 and 8.1 handle the default web application a little differently, check the docs:

WLS 8.1 - Designating a Default Web Application
 
Bansal Vinay
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi Carol Enderlin


Thanks for ur help...

As u mentioned it was due to the context root.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic