• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSP compilation error on JBOSS 7  RSS feed

 
Souvik Dasgupta
Ranch Hand
Posts: 98
Eclipse IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I am back at the forum after a long time.

I am stuck at a problem. Running an application on JDK 8 and JBoss 7. While deploying the application, getting the below error:



Need help urgently.

Regards
 
Paul Clapham
Sheriff
Posts: 22719
43
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've added this post to a couple of other forums which might be relevant.

In particular I noticed the word "eclipse" in the error report. That suggests you might be running all of this in the Eclipse IDE. If that's the case then, in my experience, you get this kind of problem if the Eclipse project is misconfigured and it doesn't have a proper reference to a valid JDK.
 
Souvik Dasgupta
Ranch Hand
Posts: 98
Eclipse IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Even I thought that after going through the answer in different forums. But after I generate the WAR is it really relevant what IDE I am using?

Also, in the same Eclipse Workspace I have few other projects, which are deploying fine.

 
Paul Clapham
Sheriff
Posts: 22719
43
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Souvik Dasgupta wrote:
Even I thought that after going through the answer in different forums. But after I generate the WAR is it really relevant what IDE I am using?

Also, in the same Eclipse Workspace I have few other projects, which are deploying fine.



Well, the JSPs are compiled by JBoss at run time, so yes it could be relevant. And it does look like Eclipse is doing the compiling, based on the error message.

Also, each Eclipse project has its own configuration to say what JDK to use, so the fact that those projects don't have that kind of compiler error doesn't tell you much. Unfortunately I haven't used JBoss in Eclipse so I can't tell you which project you should be looking at, but presumably it isn't the same project where your servlets have compiled successfully.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!