Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem with weblogic/appc

 
Anselm Paulinus
Ranch Hand
Posts: 390
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am converting an application from Weblogic 7.1 to weblogic 9.1. Get the error java.lang.NoClassDefFoundError weblogic/appc I read the postings here on Javaranch but nothing seems to be working. In my classpath I have something like this .;c:\bea\weblogic91\server\lib\weblogic.jar

Will be happy if anyone can give me some suggestions on how to go about this.

I tried to build both from command line and ant, but end up with this same error.

Thanks,
Anselm.
[ July 10, 2006: Message edited by: Anselm Paulinus ]
 
Anselm Paulinus
Ranch Hand
Posts: 390
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
copied weblogic.jar into my make directory and is picked up by Ant I suppose but then another error crept up
<weblogic.appc failed to compile your application. Recompile with the -verbose option for
more details. Please see the error message(s) below.>
[exec] Result: 1
[exec] com/bea/xml/XmlException
 
Joe Ess
Bartender
Posts: 9312
10
Linux Mac OS X Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
So did you recompile using "-verbose" so you could see the error? I know Weblogic versions get more strict with XML parsing with each new version, so you may have had something that slipped past in an older version.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic