This week's book giveaway is in the General Computing forum.
We're giving away four copies of Emmy in the Key of Code and have Aimee Lucido on-line!
See this thread for details.
Win a copy of Emmy in the Key of Code this week in the General Computing forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Paweł Baczyński
  • Piet Souris
  • Vijitha Kumara

How to debug weblogic applications using eclipse

 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My new job requires me to use Eclipse. I am normally an intellij idea user. What is the best way to debug weblogic applications with eclipse? Is there one plugin better than the other?

Your help is appreciated,

Joshua
 
J. Adam White
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I should have mentioned that I am currently using weblogic 8.1.

Thanks,

Joshua
 
Bartender
Posts: 9586
13
Mac OS X Linux Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
have a look at this article.
 
J. Adam White
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just what I was looking for... thanks!
 
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Friends,

Whatever you mentioned in the document for a web application i did the same thing but i am getting Exception..

Failed to connect to remote VM. Connection refused

Could you please help me on this...
 
Joe Ess
Bartender
Posts: 9586
13
Mac OS X Linux Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you follow the step in the article marked "Configuring a Remote Debugging Configuration in Eclipse"? You have to tell the JVM to listen for connections.
 
Thummalashankar Reddy
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
According to that article only...
I am adding JAVA_OPTS to the .cmd file
Next I configure Remote debug in the Eclipse.
Next i specified the break points..Next started the server...
Still i am getting "Unable to connect VM" only..Could you please help me on this.
 
Joe Ess
Bartender
Posts: 9586
13
Mac OS X Linux Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to tell the details.
What are you setting JAVA_OPTS to in startWeblogic.cmd?
Does your command line in startWeblogic.cmd use JAVA_OPTS?
Do you print out your command line in startWeblogic.cmd? If not, you should so you can make sure the settings are what you think they are.
What are you setting the remote debug settings to?
 
My pie came with a little toothpic holding up this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!