• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

connection timeout error

 
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Ranchars.Help needed again from you guys!!
I am using weblogic 8.1 server and Oracle 9i. One of my query in database taking more time about 8-9 minutes. My Web application calling that query is giving connection timeout after 300 seconds. Please help me where to increase this connection timeout value.Thanks in advance.
 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Increase your JTA timeout value in the admin console. You should find it under the domain tab --> JTA page.

Chang
 
Dattatray Sutar
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Chang Iych:
Increase your JTA timeout value in the admin console. You should find it under the domain tab --> JTA page.

Chang



Thanks Chang. I got the solution. Since my application is having some queries which overall taking 6-7 minutes (unfortunately )I have increased the transaction timeout period in my DD to 420 seconds(7 minutes) and also the stuck thread max time of my server to 420 seconds. Everything is working fine now.
 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Setting your jta high will probably solve your problem, but you might think that an synchronous transaction taking 5 minutes is something that needs to be removed. Imagine a production environment with 25 execute threads, and 25 users blocking these threads...
In that case, you should isolate these transactions, and make them asynchronous...
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
reply
    Bookmark Topic Watch Topic
  • New Topic