Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

XDoclet with Weblogic 9.2

 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We're thinking about upgrading to Weblogic 9.2 (from Weblogic 8.1). The biggest issue in our way currently is that there's a lot of EJBs using XDoclet ... XDoclet currently doesn't support generating weblogic deployment descriptors for anything higher than 8.1. Anyone else run into this issue? Any solutions?
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Our solution so far - have XDoclet generate everything to 8.1 spec, then run weblogic.DDConverter on the resulting WAR/EJB JAR/EAR and update the archive with the 9.2 spec deployment descriptors.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic