• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

Errors in weblogic log. Users getting timed out.

 
Ranch Hand
Posts: 38
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi there,
Users are getting disconnected/timedout when working on the application.
upon reading through the log file for BEA-101083 error, did increase the default timeout for "Complete Message Time Out to 480 seconds", and still seeing the errors on the
log file, any other setting needs to be modified? please advice.
Thanks/t



environment details:
PT 8.49.06
Web server on: Windows 2003
Bea Weblogic: weblogic 9.2 mp1-p2


from your logs,timeout error:

####<Sep 18, 2008 11:55:02 AM PDT> <Error> <HTTP> <UCBFASP1> <PIA> <[STANDBY] ExecuteThread: '7' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1221764102106> <BEA-101083> <Connection failure.
java.io.IOException: A complete message could not be read on socket: 'weblogic.servlet.internal.MuxableSocketHTTP@1887305:Socket[addr=/10.88.10.56,port=28982,localport=7001] - idle timeout: '30000' ms, socket timeout: '30000' ms', in the configured timeout period of '60' secs
at weblogic.socket.SocketMuxer$TimerListenerImpl.timerExpired(SocketMuxer.java:947)
at weblogic.timers.internal.TimerImpl.run(TimerImpl.java:265)
at weblogic.work.ServerWorkManagerImpl$WorkAdapterImpl.run(ServerWorkManagerImpl.java:518)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)
>

Cause:
-----------

The above error indicates that the default configured timeout period of '60' secs is not sufficinet to transfer the complete message to the server.

Resolution:
-------------------

Increase the Complete Message Time Out to 480 seconds in weblogic console:

Server --> Protocols --> General -> Advanced Attributes -> Complete Message Timeout

You must reboot the server.
 
reply
    Bookmark Topic Watch Topic
  • New Topic