• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Devaka Cooray
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Tim Holloway
  • Claude Moore
  • Stephan van Hulst
Bartenders:
  • Winston Gutkowski
  • Carey Brown
  • Frits Walraven

Wildfly 13 and EJB 2.1 compatibility issue and RelativeContext Classcast issue  RSS feed

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can anyone help to solve the below issue:





I am trying to upgrade my application server from JBOSS 6 to Wildfly 12/13. My Application is EJB based. When i am using Jboss 6, I used Jdk 1.7 Now for Wildfly, i am using jdk 1.8.

And, while upgrading to Wildfly, previous jndi settings also not working so i updated jndi configurations from

configurations file:





to:

configurations file:





Now i am getting error as:





ServiceLocator class:




I even added jboss-client from wildfly-13 - bin/client folder. I tried almost everyway posted in other Q&A's but nothing worked.

In other way:

I tried to convert ejb 2 to ejb 3. but since i have 3 ejb's, i didn't get any example how to convert serviceFactory and ServiceLocator classes code to ejb3.



Thanks for help in advance..

 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!