• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Devaka Cooray
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Junilu Lacar
  • Paul Clapham
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • salvin francis
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Installed Tomcat 9 now it can't find some files  RSS feed

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.

I was trying to use Java to connect with Oauth1a authentication. It wouldn't work because as the browsers said, "Cannot securely connect to this page. This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner."

So I thought to try Tomcat 9 with the possible idea that TLS is now outdated for API's? (quite possibly chasing a red herring here anyway)

Anyway, after I run a successful Maven build, when I try to run the server, it come up with the following error:
Publishing failed with multiple errors
File not found: C:\Users\--------\target\m2e-wtp\web-resources\META-INF\MANIFEST.MF.
File not found: C:\Users\-----------\target\m2e-wtp\web-resources\META-INF\MANIFEST.MF.
File not found: C:\Users\-----------------\target\m2e-wtp\web-resources\META-INF\maven\Xero-sdk-3\Xero-sdk-3\pom.properties.
File not found: C:\Users\-------------\target\m2e-wtp\web-resources\META-INF\maven\Xero-sdk-3\Xero-sdk-3\pom.properties.
File not found: C:\Users\------------------\target\m2e-wtp\web-resources\META-INF\maven\Xero-sdk-3\Xero-sdk-3\pom.xml.
File not found: C:\Users\--------------------\target\m2e-wtp\web-resources\META-INF\maven\Xero-sdk-3\Xero-sdk-3\pom.xml.
(removed a couple of folders there...)

But when I navigate into the address, they exist there.

That's it. No further information given.

I have tried a couple of ways, refreshed, restarted, took Maven off and on again....

When I go to run it, it says tomcat is stopped, not sure if it should say running here...

There is only one further clue possibly, that I was not offered to create a web.xml file, not sure how important that is or what it's for.

This is the first time I am trying to achieve this and really the first time I've needed Tomcat so I am pretty stumped.
 
Celyn Alexander
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Never mind I rolled back to Tomcat 8 for now.
 
All of the world's problems can be solved in a garden - Geoff Lawton. Tiny ad:
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!