Win a copy of Spring in Action (5th edition) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • paul wheaton
Saloon Keepers:
  • Ganesh Patekar
  • Frits Walraven
  • Tim Moores
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Stephan van Hulst
  • salvin francis
  • Tim Holloway

Help with Android Studio 3.2.1  RSS feed

 
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello, I am using Andriod Studio 3.2.1. In the build. gradle (app), I have:
dependencies {
   implementation fileTree(dir: 'libs', include: ['*.jar'])
   testImplementation 'junit:junit:4.12'
   implementation 'com.android.support:appcompat-v7:28.0.0'
   implementation 'com.github.bumptech.glide:glide:3.7.0'
   implementation 'com.android.support:support-v4:23.4.0'
   implementation 'com.mcxiaoke.volley:library:1.0.19'
   implementation 'com.google.code.gson:gson:2.6.1'
   implementation 'com.github.pavlospt:circleview:1.2'
}

Now implementation 'com.android.support:appcompat-v7:28.0.0' and implementation 'com.android.support:support-v4:23.4.0' both has a red under curly score, why is that?
 
Ranch Hand
Posts: 146
1
Android Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
These two lines should follow the targetSdkVersion.
For me, I set targetSdkVersion as 27, so this line should be
 
tony baloni
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Randy Tong wrote:These two lines should follow the targetSdkVersion.
For me, I set targetSdkVersion as 27, so this line should be



Thank you for the reply.
The thing is implementation 'com.android.support:appcompat-v7:28.0.0' is automatically gernerated when I started a new project. So I assume it is the right version. I use lollipop 5.1 on my Android Studio. The implementation 'com.android.support:support-v4:23.4.0' is I copied from a sample frome a tutorial code which is a few years old. So I assume it is out of date. How do I know which verson goes with 'com.android.support:appcompat-v7:28.0.0'? My SDK Manager looks like this, don't know if it matters.
1.png
[Thumbnail for 1.png]
2.png
[Thumbnail for 2.png]
 
Randy Tong
Ranch Hand
Posts: 146
1
Android Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

The implementation 'com.android.support:support-v4:23.4.0' is I copied from a sample frome a tutorial code which is a few years old.


Will you get any errors after you remove this?
 
Randy Tong
Ranch Hand
Posts: 146
1
Android Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

How do I know which verson goes with 'com.android.support:appcompat-v7:28.0.0'?


Is there any reasons why you need to know since it will automatically generated ?

This is mine (for Sdk 17)
 
The moth suit and wings road is much more exciting than taxes. Or this tiny ad:
Download Free Java APIs to Work with Office Files and PDF
htttp://www.e-iceblue.com/free-apis.html
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!