Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

unable to open store service tool in wcs 5.1

 
Thirupathi Rajan
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I got a problem while working in WCS 5.1 Version.I have created Instance and published the Store archive file using the store tool service yesterday.Launched the stores also.Today i unable to open the stores service tool.I got the error as Http Web Controller is not executed in the log file(ecmsg).After wards, I restarted the machine still same thing continues but i unable to get the error in the log files also. Thanx in Advance

regards,
Thirupathi Rajan
 
Ashok NMR
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
can u show the errors in the log file?
 
Thirupathi Rajan
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Error in WCS 5.1
First time when the service tool was not running. i got the error execute view command of Http Controller is not executed in the log file.After that, i tried by restarting the computer.Now also, i am unable to run the store service tools and any other servlet.Now i didn't any message in the log files also.Do you have any solution?
[This message has been edited by Thirupathi Rajan (edited August 09, 2001).]
 
madhu pa
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Rajan !!
Have started ur WAS??
Regards,
Madhu
 
Thirupathi Rajan
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi madhu,
I started WAS and it's running,corresponding WCS Server also running and unable to run the store service, i want to know the reason why it is store service stopped.I re-installed from the scratch.It's working fine.
Again i installed WCS in the different machine, i published nearly 10 stores but while creating instance licence manager, i specified Licence for the single store.I got the licence error and afterwards tools are not working? I have changed the store licence to 15 in the IBM WCS Configuration Manager and restarted the WCS server.Till now, store services tools are not running.
Suggest a good solution,Thanx in advance.
regards,
Rajan
 
Ashok NMR
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Rajan,
If the licence exceeds,only store cannot be published.
But it won't affect store services.what do u think mathu?
rajan,did u changed the no of licence in same instance or in new instance?
 
Thirupathi Rajan
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Ashok,
I have changed Licence of the store service in the same instance itself.but store service is not working? but i included the sample servlet in the stores folder it is working fine and i am able to get the output.
while i running the store service tool or already published stores is not running.what may be the possible error .suggest a good solution,thanx in advance
Regards,
Rajan

[This message has been edited by Thirupathi Rajan (edited August 11, 2001).]
 
Ashok NMR
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi thirupati,
Did u solved that problem?
I also faced same kind of problem ie. storeservices didn't run.
when i checked the error.log i found the error stating that
"ssL handshake failed".
I found that it is due to expiration of ssl certificate.
when i assaign new certificate.It worked.
If urs is not due to this problem and if u solved that means let me know.
"let us grow together"
thanks.
 
Thirupathi Rajan
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Ashok,
Thanx for ur interest on me.
I am still got the error. I want know to how assign new ssl certificate.I gone through the error.log files.
The following error occured in this file. how to solve the error?
[Tue Aug 14 11:34:23 2001] [error] [client 10.0.247.136] Invalid method in request.
Suggest good solution,
Thanx in advance
regards,
Thirupathi
 
Ashok NMR
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I also thank u for giving me the oppertinuity to do somthing for u.
thirupati,ssl certificate certificate can be created by
Key Management utility present in IBM HTTPServer.
the path is start-->Programfiles-->IBM HTTPServer-->Key management utility.
there u can create self certificate and also create request for certificate by company like verisign.
--------------------
after putting certificate restart and check the following:
1.wheather all services are running?
2.ssl is enabled in configuration manager?(by default it is enabled).
3.check the files like.. admin.conf,access.log,activity.log etc.
let me know.
all the best
 
Ashok NMR
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
in error.log i got like this
[Sun Jun 03 13:55:46 2001] [error] [client 127.0.0.1] Invalid method in request �C
At the "same time" in access.log i got
127.0.0.1 - - [03/Jun/2001:13:55:46 -0400] "GET /webapp/wcs/tools/servlet/ToolsLogon?XMLFile=adminconsole.AdminConsoleLogon HTTP/1.1" 302 5
127.0.0.1 - - [03/Jun/2001:13:55:46 -0400] "�C__" 501 -
127.0.0.1 - - [03/Jun/2001:13:55:49 -0400] "GET /webapp/wcs/tools/servlet/ToolsLogon?XMLFile=adminconsole.AdminConsoleLogon HTTP/1.1" 302 5
127.0.0.1 - - [03/Jun/2001:13:55:49 -0400] "�C__" 501 -
127.0.0.1 - - [03/Jun/2001:13:55:57 -0400] "�C__" 501 -
127.0.0.1 - - [03/Jun/2001:13:56:04 -0400] "�C__" 501 -
127.0.0.1 - - [03/Jun/2001:13:56:52 -0400] "�C__" 501 -
-------------
this was due to "application server didn't started".
 
Thirupathi Rajan
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Ashok,
In error.log
i got the same error as you said the last posting. here i copied the same error and diplayed.
[Sun Jun 03 13:55:46 2001] [error] [client 127.0.0.1] Invalid method in request �C
At the "same time" in access.log i got
127.0.0.1 - - [03/Jun/2001:13:55:46 -0400] "GET /webapp/wcs/tools/servlet/ToolsLogon?XMLFile=adminconsole.AdminConsoleLogon HTTP/1.1" 302 5
127.0.0.1 - - [03/Jun/2001:13:55:46 -0400] "�C__" 501 -
127.0.0.1 - - [03/Jun/2001:13:55:49 -0400] "GET /webapp/wcs/tools/servlet/ToolsLogon?XMLFile=adminconsole.AdminConsoleLogon HTTP/1.1" 302 5
127.0.0.1 - - [03/Jun/2001:13:55:49 -0400] "�C__" 501 -
127.0.0.1 - - [03/Jun/2001:13:55:57 -0400] "�C__" 501 -
127.0.0.1 - - [03/Jun/2001:13:56:04 -0400] "�C__" 501 -
127.0.0.1 - - [03/Jun/2001:13:56:52 -0400] "�C__" 501 -
-------------
In the WAS admin console, I saw the current state of WCS Server is running.
Do you have any other solution?
--Thirupathi Rajan
 
Thirupathi Rajan
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Again i got the following error in the ecmg_*_*.log files
TimeStamp: 2001-08-23 16:50:18.53
Thread ID: <CacheCleanupWorker>
Class: com.ibm.commerce.cache.daemon.CacheCleanupWorker
Method: requestCPDL
Severity: 1
Message Text: CMN0814E There was an error when interacting with CachePageDeletionList : http://localhost:80/webapp/wcs/stores/servlet/CachePageDeletionList?startTime=998398790000&startTimeNanos=104000000.
Exception: com.ibm.commerce.cache.daemon.CPDLException
at com.ibm.sfc.cmd.CommandException.<init>(CommandException.java)
at com.ibm.commerce.exception.ECException.<init>(ECException.java)
at com.ibm.commerce.exception.ECSystemException.<init>(ECSystemException.java)
at com.ibm.commerce.cache.daemon.CPDLException.<init>(CPDLException.java)
at com.ibm.commerce.cache.daemon.CacheCleanupWorker.requestCPDL(CacheCleanupWorker.java)
at com.ibm.commerce.cache.daemon.CacheCleanupWorker.doCleanup(CacheCleanupWorker.java)
at com.ibm.commerce.cache.daemon.CacheCleanupWorker.run(CacheCleanupWorker.java)
at java.lang.Thread.run(Thread.java:481)
Still Store Services are not running. can you help solving my problem?
regards,
Thirupathi

 
Ashok NMR
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Iam sorry Thirupati,
I don't know.
..............
Is there anyone who is using this form have any suggestionssssssssss?
Atleast try to comment something on this.
 
madhu pa
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi !!
My Administration Console and Store Services r not starting .
Earlier it was SSL Certification problem .For that i have created new Certificate.But now it gives this error----
[Fri Aug 31 12:02:00 2001] [error] [client 132.186.151.6] File does not exist: d:/websphere/ibm http server/htdocs2/default.ida
BTW i have created two instances (one of which was for Staging server) and also my m/c's IP has changed.It this problem is b'coz of any of these reasons???
Please help me out soooon.
Thanks in advance
Regards,
madhu
 
Bharath Katragadda
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Tripati Rajan,
I am unable to run the sample store InFashion provided with WCS 5.1. When I try to access that I get the following error message:
TimeStamp: 2001-11-26 18:24:24.473
Thread ID: <CacheCleanupWorker>
Class: com.ibm.commerce.cache.daemon.CacheCleanupWorker
Method: requestCPDL
Severity: 1
Message Text: CMN0814E There was an error when interacting with CachePageDeletionList : http://localhost:80/webapp/wcs/stores/servlet/CachePageDeletionList?startTime=1006790347000&startTimeNanos=645001000.
Exception: com.ibm.commerce.cache.daemon.CPDLException
java.lang.Throwable()
java.lang.Exception()
com.ibm.sfc.cmd.CommandException()
com.ibm.commerce.exception.ECException()
com.ibm.commerce.exception.ECSystemException(com.ibm.commerce.ras.ECMessage, java.lang.String, java.lang.String, java.lang.Object [])
com.ibm.commerce.cache.daemon.CPDLException(com.ibm.commerce.ras.ECMessage, java.lang.String, java.lang.String, java.lang.Object [])
com.ibm.commerce.cache.daemon.CPDLResponse com.ibm.commerce.cache.daemon.CacheCleanupWorker.requestCPDL()
boolean com.ibm.commerce.cache.daemon.CacheCleanupWorker.doCleanup()
void com.ibm.commerce.cache.daemon.CacheCleanupWorker.run()
void java.lang.Thread.run()
You have a solution for this...So, please help me out..
Thanks,
Bharath Katragadda
 
Thirupathi Rajan
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi bharath,
see what error present in access.log file and error.log files.
get back to me.
regards,
Thirupathi
 
Bharath Katragadda
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Thirupati Rajan,
1.This is the error I discovered in the access.log file:
127.0.0.1 - - [26/Nov/2001:19:06:18 +0100] "GET /webapp/wcs/stores/servlet/CachePageDeletionList?startTime=1006790347000&startTimeNanos=645001000 HTTP/1.0" 500 524
2.This is the error I discovered in the error.log file:
[Mon Nov 26 18:39:31 2001] [error] [client 127.0.0.1] File does not exist: c:/websphere/wcs/web/doc/en_us/nav/search$comclassobject.class
Please clarify on this...
Regards,
Bharath Katragadda
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic