Win a copy of Python Continuous Integration and Delivery this week in the Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Devaka Cooray
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Tim Holloway
  • Claude Moore
  • Stephan van Hulst
Bartenders:
  • Winston Gutkowski
  • Carey Brown
  • Frits Walraven

[ERROR] Manifest com.x:com.x-y:atlassian-plugin:1.0.0 : The default package '.' is not permitted  RSS feed

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
0. How to fix this error?
1. Should I place all dependencies to Import-Package? Only packages, used in my code from this libs
or root packages of dependencies?
2. If last, how to define root packages, should I manually open jar to see it?
Because from errors I see that Import-Package does not corresponds to groupId.
3. Do we have only maven way to build the plugin?
4. Why plugin requires additional oracle dependencies, when other java
apps need only jdbc driver?
Such great JIRA for users, but development of plugins is a hell for me (and other developers, I read).
I spent several nights without any pogress and there are no practical examples with dependencies- just fictional 'my-lib*'.

additional thank you for
1. postgres,
2. mysql and
3. mssql

instructions, if they includes more than one libraries for each case
4. in addition to mentioned oracle.

sqldrivers described only for JIRA server setup in docs.

POM
please, check pastebin
 
Saloon Keeper
Posts: 2406
296
Android Angular Framework Eclipse IDE Java Linux MySQL Database Redhat TypeScript
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is your code in a proper (non-default) package?
 
Arthur Harkivsky
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it is in com.x*
 
Ron McLeod
Saloon Keeper
Posts: 2406
296
Android Angular Framework Eclipse IDE Java Linux MySQL Database Redhat TypeScript
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am just guessing, but maybe one of your dependencies has classes in the default package?
 
Ron McLeod
Saloon Keeper
Posts: 2406
296
Android Angular Framework Eclipse IDE Java Linux MySQL Database Redhat TypeScript
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
lombok-1.18.4 has a class file named module-info.class in the default package - I wonder if that could be causing your problem??

Maybe try rolling back to lombok-1.16.20 and see if that helps (again, this is just a guess).
 
Arthur Harkivsky
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
fixed lombok version, but error is same.

thank you 1000 times for any help!
 
Stinging nettles are edible. But I really want to see you try to eat this tiny ad:
Become a Java guru with IntelliJ IDEA
https://www.jetbrains.com/idea/
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!