Daniel Demesmaecker wrote:no it should'nt 0 5 and 8 is dioginal from left upper to right botomcorner
Daniel Demesmaecker wrote:What do you mean by making it more object oriented, we're talking about components, they're allready objects no?
Pleae read this. Please ask the question on your thread. And have you answered the questions I asked you yesterday?
Ana Yo wrote:. . . I was the one who asked him to help me . . .
So does the use of icons on buttons. Testing which icon is on which button, particularly with numbers like 1 and 2, couples the game logic to the display, and also puts the cart before the horse. The idea of a GUI is to display what the state of the game is, but here it determines what the state of the game is. As we have already seen, the use of magic numbers can be error‑prone.
Junilu Lacar wrote:. . . a call to . . . tightly couples the display logic to the main game loop. . . .
Campbell Ritchie wrote:I can see problems with a getWinner() method; what is that method going to do when there is no winner yet, and when there are still vacant squares?
Campbell Ritchie wrote:I would prefer this sort of method name:- while (game.inProgress()) ...
Junilu Lacar wrote:. . . you're coming from the perspective that this code: . . . is more difficult to read
. . . . with a name like "notOver()" there is no translation involved . . .
Daniel Demesmaecker wrote:cause I was lazy . . .