This week's book giveaway is in the Go forum.
We're giving away four copies of Head First Go and have Jay McGavren on-line!
See this thread for details.
Win a copy of Head First Go this week in the Go forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Devaka Cooray
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Tim Holloway
  • Claude Moore
  • Stephan van Hulst
Bartenders:
  • Winston Gutkowski
  • Carey Brown
  • Frits Walraven

Compiling Android system on Linux MInt  RSS feed

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have been trying to compile an android Marshmello system with no success. every time i try to compile i get this error

javac: invalid source release: 1.7s
Usage: javac <options> <source files>
make: *** [out/target/common/obj/JAVA_LIBRARIES/ext_intermediates/classes-full-debug.jar] Error 41
#### make failed to build some targets (03:04 (mm:ss)) ####

when i check my java and javac version i get this:

javac 1.7.0_161
java version "1.7.0_161"
OpenJDK Runtime Environment (IcedTea 2.6.12) (7u161-2.6.12-1)
OpenJDK 64-Bit Server VM (build 24.161-b01, mixed mode)

which seems to be the correct version for my system

i have set JAVA_HOME and ANDROID_JAVA_HOME to the following paths in the bash.rc file

echo $ANDROID_JAVA_HOME  
/usr/lib/jvm/java-7-openjdk-amd64

echo $JAVA_HOME
/usr/lib/jvm/java-7-openjdk-amd64

yet nothing seems to work and i keep getting the same error. can anyone help me? thank you
 
Saloon Keeper
Posts: 20514
115
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the Ranch, Gil!

It says version 1.7s. Are you sure that's correct? You might have a typographical error in something.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!