This week's book giveaway is in the OCAJP forum.
We're giving away four copies of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) and have Khalid A Mughal & Rolf W Rasmussen on-line!
See this thread for details.
Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Struts and WSAD

 
Randy Thomasson
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does anyone know where I can find information about using the Apache Struts framework with the WebSphere Studio Application Developer?
Thanks,
Randy Thomasson
 
markchen
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Randy,
Have you found it out? Any help is appreciated.
Mark
 
Tim Holloway
Saloon Keeper
Pie
Posts: 18277
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Heck, I'm still waiting in vain for an answer on what it takes to RUN a Struts app under WAS 4!
 
SubbaRao,PV
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What info you need? We are currently using Struts on WAS 3.5.4 with Fixpack ---(6, I think).
 
Tim Holloway
Saloon Keeper
Pie
Posts: 18277
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
According to the docs at jakarta.apache.org, you had to make changes to the Struts source code to run under WAS 3.5. I was just trying to find out if that still applied under WAS 4 or if they can now use the "out-of-the-box" struts.jar file.
 
Abe Rowland
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WAS 4.0.x uses Struts in it's Web Console. I have implemented Struts in both WASAD and in WAS 4.0.1 without making any code changes to the Struts Framework. I did have to move some of the files around a bit in WASAD to get everything to work properly. As a hint though, I could never get the DTD's to be recognized using a fully qualified path (d:\classes\dtds\...). As well, if you put them in your web application, they will not be found because they are needed prior to the web app being initialized. My workaround for this was to just leave the URL in the .tld's as they are, for example [< !DOCTYPE taglib PUBLIC "-//Sun Microsystems, Inc.//DTD JSP Tag Library 1.1//EN" "http://java.sun.com/j2ee/dtds/web-jsptaglibrary_1_1.dtd">]
....
Hope this helps
 
Peter DeGregorio
Greenhorn
Posts: 10
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WSAD (I am using 4.0.3) runs Struts without a fuss. Import the Struts example WAR into a new web project and it should run without a problem.
 
Tim Holloway
Saloon Keeper
Pie
Posts: 18277
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks. That narrows down my problem. Now if I could just get the deployer to give me a more meaningful message than "I hate your EAR file"...
 
david chan
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I can successfully run the struts 1.0.2 example.war in WASD 4.0.2 test environment, but I can't deploy it to Websphere AEs 4.0.3. Here is how I did:
First I try to export the struts example to a war file in WASD, then in AEs' admin console, I click the install button, and select the war, and put application name, context root, then install, but not success. The only error message I got is "this web module cannot be run". no any details.
What's wrong? ( I can deploy the war file in tomcat like light fast.)
David
 
sssmokin
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to run my webapp which is struts based on version 4.03. I got the struts-example to work fine but I keep getting an error 5533d6cc WebGroup X Servlet Error-[action]: Failed to load servlet: java.lang.ClassCastException: org.apache.struts.action.ActionServlet
What is the deal? My setup is EXACTLY like for the struts example app. Any ideas?
Thanks,
Dave
 
Thirumaran Somasundaram
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I started working in WSAD 5.0....it seem to be a dream tool for developers......i hope Struts will work in this new version.....does any one aware of how to go about with struts in WSAD 5.0 from the sratch???
 
Nehal Vaidya
Greenhorn
Posts: 14
Java jQuery Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
https://www6.software.ibm.com/developerworks/education/x-iextreme19/?
 
rooford Johnson
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by sssmokin:
I am trying to run my webapp which is struts based on version 4.03. I got the struts-example to work fine but I keep getting an error 5533d6cc WebGroup X Servlet Error-[action]: Failed to load servlet: java.lang.ClassCastException: org.apache.struts.action.ActionServlet
What is the deal? My setup is EXACTLY like for the struts example app. Any ideas?
Thanks,
Dave
 
rooford Johnson
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by sssmokin:
I am trying to run my webapp which is struts based on version 4.03. I got the struts-example to work fine but I keep getting an error 5533d6cc WebGroup X Servlet Error-[action]: Failed to load servlet: java.lang.ClassCastException: org.apache.struts.action.ActionServlet
What is the deal? My setup is EXACTLY like for the struts example app. Any ideas?
Thanks,
Dave

I had this problem. Running WSAD 4.04 and Struts. The problem in my case was a third party jar file in WEB-INF/lib which had javax.servlet.http.HttpServlet;
defined in it. I extracted the jar and removed all the classes and packages from javax down. This fixed the problem. It also defined some XML parser classes which also caused a similar problem. In short remove everything from WEB-INF/lib other struts.jar and start the server, then if all works start adding the jar files required one by one until you find the culprite.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic