By the same token, I would have expected you to be able to do this:
I would have expected the getContentFile() method to be overloaded so that it can take a String path argument as well as a File file argument.
Also, that method name is somewhat misleading. If it's getting the content of the file specified by the argument, a better name for that method would be just getContent(). That way, the code wouldn't be so repetitive and stutter-y.
The best ideas are the crazy ones. If you have a crazy idea and it works, it's really valuable.—Kent Beck