This week's book giveaway is in the Spring forum.
We're giving away four copies of Spring in Action (5th edition) and have Craig Walls on-line!
See this thread for details.
Win a copy of Spring in Action (5th edition) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • paul wheaton
Saloon Keepers:
  • Ganesh Patekar
  • Frits Walraven
  • Tim Moores
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Stephan van Hulst
  • salvin francis
  • Tim Holloway

Form-based login in WAS 4.0.2  RSS feed

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I can't seem to get form-based authentication to work in WAS 4.0.2 - using SecureWay 3.2.1 and DB2 7.2
I've tried both the j_security_check and a custom login servlet - neither is completely successful.
Using the custom-login servlet, after what seems like successful authentication, access to the protected resource is still redirected to the login page (I also had to code the redirect myself)
Using j_security_check the redirect is to my welcome page defined in my web app's deployment descriptor - which is not the protected resource I originally requested. Subsequent requests to protected resources still redirect me to the login form.
Has anyone got a .war of form-based authentication in WAS 4.0.2 that works?
Thanks.
 
Bill M
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Fixed. I was using "localhost" for ltpa/ldap (sso enabled), so changed that to a fully qualified name. I also reconfigured Secureway to use the same fully qualified name instead of "localhost" as well. I also configured the proper AdminRole user in the Security Centre and all seems to be working properly now.
[ February 20, 2002: Message edited by: Bill M ]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!