Win a copy of Kotlin for Android App Development this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Devaka Cooray
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Junilu Lacar
  • Paul Clapham
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • salvin francis
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

error with j_security_check  RSS feed

 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
From: xenoux@yahoo.com (xenoux)
Newsgroups: ibm.software.websphere.application-server
Subject: j_security_check
NNTP-Posting-Host: 63.84.90.184
Message-ID: <bb9d19e4.0203111735.416a4bd9@posting.google.com>
I have a strange problem, can someone tell me what is wrong?
I use form based authentication with Websphere using custom registry,
setup in web.xml is as below.
when I tried to access a protected resource URL,
http://bhn.gers.com:9080/furnnet/main/dispatcher.do, since everything
under dir "/main" is defined to be protected in the web.xml, I was
brought to the login page as expected, after submit the form with the
j_username and j_password, I got a 404 file not found, as below,
but in fact the user had been authenticated because if I resubmit the
same URL link, I was able to access that URL link.
Can someon tell me what is wrong with it or my setup?
thanks
Binh
-----------------------------------------------------------------------
404 Error Message:
http://bhn.gers.com:9080/furnnet/j_security_check

The page cannot be found
The page you are looking for might have been removed, had its name
changed, or is temporarily unavailable.
--------------------------------------------------------------------------------
Please try the following:
If you typed the page address in the Address bar, make sure that it is
spelled correctly.
Open the bhn.gers.com:9080 home page, and then look for links to the
information you want.
Click the Back button to try another link.
Click Search to look for information on the Internet.
HTTP 404 - File not found
Internet Explorer
-----------------------------------------------
< !--<br /> web.xml file:<br /> <security-constraint id="SecurityConstraint_1"><br /> <web-resource-collection id="WebResourceCollection_1"><br /> <web-resource-name>fn access</web-resource-name><br /> <url-pattern>/main/*</url-pattern><br /> <br /> <http-method>POST</http-method><br /> <http-method>GET</http-method><br /> </web-resource-collection><br /> <auth-constraint id="AuthConstraint_1"><br /> <description>fn access:+:</description><br /> <role-name>fnUser</role-name><br /> </auth-constraint><br /> <user-data-constraint id="UserDataConstraint_1"><br /> <transport-guarantee>NONE</transport-guarantee><br /> </user-data-constraint><br /> </security-constraint><br /> <login-config id="LoginConfig_1"><br /> <auth-method>FORM</auth-method><br /> <realm-name>dbRealm</realm-name><br /> <form-login-config id="FormLoginConfig_1"><br /> <form-login-page>/logon.html</form-login-page><br /> <form-error-page>/error.jsp</form-error-page><br /> </form-login-config><br /> </login-config><br /> <security-role id="SecurityRole_1"><br /> <role-name>fnUser</role-name><br /> </security-role><br /> -->
 
Ranch Hand
Posts: 319
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Bing,

How did you solve this issue? I have this problem now. What is even more weirder is that I have this problem only with IE and not with Firefox/Opera
 
All of the world's problems can be solved in a garden - Geoff Lawton. Tiny ad:
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!