Please indent all your code correctly. It is you who will have difficulty caused by code difficult to read.
Please find out why that constructor ought to be private. Also why it would be better to move all that code out of your main() method, in which case maybe you can have a public constructor after all.
I think that Main is a very bad name for a class, even if NetBeans suggests the name for you.