Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Port 9080

 
Kishan Kumar
Ranch Hand
Posts: 130
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I have configured HTTP SERVER to SSL. But while I try to access through https://medtest/
It is telling File Not Found. But when I access through http://medtest:9080/ the application is working fine. Are both the invocations same in terms of security ??. what is the significance of the port number here?. I have to make it work with https://medtest/ Am I missing something ??
When I give https it is searching for files in /htdocs while it should search in .ear directory.
Somewhere I read if i add
AddModule mod_app_server_http.c to httpd.conf it will work ... But after this HTTP server is itself not starting. Please help me out...Iam a newbie to websphere.
Thanks,
Kishan
 
Matt Anderson
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
when you are typing the url without a port, it will take u to default port ...8080 or 80. either you need to configure websphere to listen on the default port(8080) or you may need to redirect all the request on default port to port 9080.
Matt
 
mahadevan raja
Ranch Hand
Posts: 96
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
port 9080 is the default internal webserver provided with the app server for testing purposes.... just check ur plugin-cfg.xml for entries made with respect to SSL.
i believe that those entries were made wrt the 9080 port .
u could check that out..
 
Steve Granton
Ranch Hand
Posts: 200
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I also have the same problem.
I've got two instances of 9080 in my plugin-cfg.xml file:
VirtualHostGroup Name="default_host"
VirtualHost Name="*:80"
VirtualHost Name="*:9080"
VirtualHostGroup
and
ServerGroup Name="weblog2/Default Server"
Server CloneID="tljqhh5s" Name="Default Server"
Transport Hostname="weblog2" Port="9080" Protocol="http"
Server
ServerGroup
Which of these do I need to change in order that requests on port 80 will be routed to Websphere?
Also, if I have static content on the Web Server then presumably these will be served in preference to routing to webpshere if the request is on port 80?
Presumably after any changes I'll need to regenerate the webserver plugin?
Cheers,
Steve
[ April 30, 2002: Message edited by: Steve Granton ]
[ April 30, 2002: Message edited by: Steve Granton ]
[ April 30, 2002: Message edited by: Steve Granton ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic