Last week, we had the author of TDD for a Shopping Website LiveProject. Friday at 11am Ranch time, Steven Solomon will be hosting a live TDD session just for us. See for the agenda and registration link
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Jdbc/Odbc Bridge Problem! Please, help!

 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi, there.
We had an app runnning on top of WebSphere Application Server 3.0.2.
The database is on SQL Server 7.0 (Yeah, I know, no big deal).
And the connection was driven by an jdbc/odbc bridge (yeah, I know too, deep problem).
But it was working (with some problems).
We migrated the app to WAS 3.5
I upgrade the app using VAJ 3.5 and everything works fine.
The servlets and jsp's are working perfectly, the SQL queries have been optimized, and everybody was happy.
(The first question here is .. Kyle (Brown) you say "It's never going to work. We don't support the JDBC/odbc bridge as a datasource in VAJ or WebSphere..." in a message posted in JavaRanch about "Unrecognized database or driver "sun.jdbc.odbc.JdbcOdbcDriver"; using generic settings" but in my VAJ 3.5 it's working just fine, why ?)
Up to this moment everything was fine, but .. when I install my webapp in WAS 3.5 I have the same error that the boy with the message in JavaRanch
Unrecognized database or driver
"sun.jdbc.odbc.JdbcOdbcDriver"; using generic settings
How is this possible ? How I do resolve this ?
I know that when could buy a jdbc driver for SQL
Server but I would like to know is there is another
option (as few money we expense, the better)?
In VAJ 3.5 my app runs OK and in WAS 3.5 the driver is not supported ?
Please, help us 'cause we don't know what to do and we're slipping from our deadline.
Thanks in advance.
 
Legend has it that if you rub the right tiny ad, a genie comes out.
free, earth-friendly heat - a kickstarter for putting coin in your pocket while saving the earth
https://coderanch.com/t/751654/free-earth-friendly-heat-kickstarter
reply
    Bookmark Topic Watch Topic
  • New Topic