• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

WAS 5.0: Verify Installation failure

 
Ranch Hand
Posts: 233
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
When doing Verify Installation from First Steps to confirm the server installed and started properly, I get a verification failure,
as shown below
=======================================================
OS: Windows 2000
locale: el_GR
hostname: pc1988
cmd.exe /c "C:\Program Files\WebSphere\AppServer\bin\ivt"
IVTL0095I: defaulting to host pc1988 and port 9080
IVTL0010I: Connecting to the WebSphere Application Server pc1988 on port: 9080

IVTL0020I: Could not connect to Application Server, waiting for server to start
IVTL0025I: Attempting to start the Application Server
osName = Windows 2000
IVTL0030I: Running cmd.exe /c "C:\Program Files\WebSphere\AppServer\bin\startServer" server1
>ADMU0116I: Tool information is being logged in file C:\Program
> Files\WebSphere\AppServer\logs\server1\startServer.log
>ADMU3100I: Reading configuration for server: server1
>ADMU3200I: Server launched. Waiting for initialization status.
>ADMU3000I: Server server1 open for e-business; process id is 2592
IVTL0075I: IVT Verification Failed
IVTL0035I: Scanning the file C:\Program Files\WebSphere\AppServer\logs\server1\SystemOut.log for errors and warnings
...
[11/5/2003 12:43:07:963 GMT+02:00] 6dd47c7c ApplicationMg W WSVR0100W: An error occurred initializing, DefaultApplication
[11/5/2003 12:43:08:073 GMT+02:00] 6dd47c7c ApplicationMg W WSVR0100W: An error occurred initializing, ivtApp
[11/5/2003 12:43:08:163 GMT+02:00] 6dd47c7c ApplicationMg W WSVR0100W: An error occurred initializing, adminconsole
[11/5/2003 12:43:08:173 GMT+02:00] 6dd47c7c ApplicationMg W WSVR0100W: An error occurred initializing, SamplesGallery
[11/5/2003 12:43:08:183 GMT+02:00] 6dd47c7c ApplicationMg W WSVR0100W: An error occurred initializing, TechnologySamples
[11/5/2003 12:43:08:193 GMT+02:00] 6dd47c7c ApplicationMg W WSVR0100W: An error occurred initializing, PlantsByWebSphere
[11/5/2003 12:43:08:203 GMT+02:00] 6dd47c7c ApplicationMg W WSVR0100W: An error occurred initializing, petstore
...
IVTL0040I: 86 errors/warnings were detected in the file C:\Program Files\WebSphere\AppServer\logs\server1\SystemOut.log

IVTL0080I: Installation Verification is complete
=======================================================
When I look into SystemOut.log, I see the following:
=======================================================
[11/5/2003 12:43:07:963 GMT+02:00] 6dd47c7c ApplicationMg W WSVR0100W: An error occurred initializing, DefaultApplication
com.ibm.ws.exception.ConfigurationWarning: Failed to open C:\Program Files\WebSphere\AppServer\config\cells\pc1988\applications\DefaultApplication.ear\deployments\DefaultApplication
at com.ibm.ws.runtime.component.DeployedApplicationImpl.initialize(DeployedApplicationImpl.java:390)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.initializeApplication(ApplicationMgrImpl.java:135)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:203)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:343)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:234)
at com.ibm.ws.runtime.component.ApplicationServerImpl.start(ApplicationServerImpl.java:117)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:343)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:234)
at com.ibm.ws.runtime.component.ServerImpl.start(ServerImpl.java:182)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:135)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:232)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)
---- Begin backtrace for nested exception
com.ibm.etools.archive.exception.DeploymentDescriptorLoadException: META-INF/application.xml
Stack trace of nested exception:
com.ibm.etools.archive.exception.ResourceLoadException: IWAE0007E Could not load resource "META-INF/application.xml" in archive "C:\Program Files\WebSphere\AppServer\config\cells\pc1988\applications\DefaultApplication.ear\deployments\DefaultApplication"
Stack trace of nested exception:
com.ibm.etools.archive.exception.ArchiveRuntimeException: Invalid binaries path: C:\Program Files\WebSphere\AppServer/installedApps/pc1988/DefaultApplication.ear
at com.ibm.etools.archive.impl.LoadStrategyImpl.checkLoosePathsValid(LoadStrategyImpl.java:358)
at com.ibm.etools.archive.impl.LoadStrategyImpl.setLooseArchive(LoadStrategyImpl.java:343)
at com.ibm.etools.archive.impl.DirectoryArchiveLoadStrategyImpl.getLooseArchive(DirectoryArchiveLoadStrategyImpl.java:45)
at com.ibm.etools.archive.impl.LoadStrategyImpl.primGetResourcesPath(LoadStrategyImpl.java:133)
at com.ibm.etools.archive.impl.LoadStrategyImpl.initializeContext(LoadStrategyImpl.java:241)
at com.ibm.etools.archive.impl.LoadStrategyImpl.getContext(LoadStrategyImpl.java:160)
at com.ibm.etools.archive.impl.LoadStrategyImpl.getResourceSet(LoadStrategyImpl.java:232)
at com.ibm.etools.archive.impl.LoadStrategyImpl.getMofResource(LoadStrategyImpl.java:222)
at com.ibm.etools.commonarchive.impl.ArchiveImpl.getMofResource(ArchiveImpl.java:528)
at com.ibm.etools.commonarchive.impl.ModuleFileImpl.getDeploymentDescriptorResource(ModuleFileImpl.java:65)
at com.ibm.etools.archive.impl.XmlBasedImportStrategyImpl.primLoadDeploymentDescriptor(XmlBasedImportStrategyImpl.java:35)
at com.ibm.etools.archive.impl.Ear12ImportStrategyImpl.loadDeploymentDescriptor(Ear12ImportStrategyImpl.java:74)
at com.ibm.etools.archive.impl.Ear12ImportStrategyImpl.importMetaData(Ear12ImportStrategyImpl.java:69)
at com.ibm.etools.commonarchive.impl.EARFileImpl.getDeploymentDescriptor(EARFileImpl.java:411)
at com.ibm.etools.commonarchive.impl.EARFileImpl.initializeModuleExtensions(EARFileImpl.java:789)
at com.ibm.etools.commonarchive.impl.EARFileImpl.initializeAfterOpen(EARFileImpl.java:780)
at com.ibm.etools.commonarchive.impl.CommonarchiveFactoryImpl.openSpecificArchive(CommonarchiveFactoryImpl.java:633)
at com.ibm.etools.commonarchive.impl.CommonarchiveFactoryImpl.openEARFile(CommonarchiveFactoryImpl.java:469)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.open(DeployedApplicationImpl.java:168)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.initialize(DeployedApplicationImpl.java:386)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.initializeApplication(ApplicationMgrImpl.java:135)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:203)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:343)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:234)
at com.ibm.ws.runtime.component.ApplicationServerImpl.start(ApplicationServerImpl.java:117)
at com.ibm.ws.runtime.component.ContainerImpl.startComponents(ContainerImpl.java:343)
at com.ibm.ws.runtime.component.ContainerImpl.start(ContainerImpl.java:234)
at com.ibm.ws.runtime.component.ServerImpl.start(ServerImpl.java:182)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:135)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:232)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)
=======================================================
and a host of analogous errors for the other applications.
When going to directory pc1988, I see no EAR files under it. Please note that I performed a custom installation, whereby I elected not to install any samples.
Any clue?
 
Ranch Hand
Posts: 235
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I had same problem...see this thread:
https://coderanch.com/t/73273/Websphere/WAS-Windows-XP
 
pie. tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic