On page 181 in Chapter 4, We call back to this saying "In Chapter 3, we used Function with the merge() method."
Here too we should say BiFunction instead.
Less important, but every decrease in opportunity to mis-remember something helps...
RTFJD (the JavaDocs are your friends!) If you haven't read them in a long time, then RRTFJD (they might have changed!)