• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Android build issues with cordova

 
Ranch Hand
Posts: 160
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
have a cordova android app that I am trying to build with android version 8.1.0.

While I attempt build, I see the below error:

FAILURE: Build failed with an exception.



I can see the below in the platforms/android/build.gradle file:


There is another build.gradle in the app folder. I cant see any minsdkversion there.

Can somebody please help me to understand what the error message means and how I can resolve it?
 
Saloon Keeper
Posts: 7601
177
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It looks like the project has a dependency that requires a minimum SDK version of 14. Why that should cause an issue in a project that requires 19 is a bit of a mystery - if it was the other way around, that would make more sense.

Start by looking at the external dependencies, and see if you can upgrade those to newer versions. Also, once you find out which dependency causes this, maybe they have a support forum where you can ask about this.
 
reply
    Bookmark Topic Watch Topic
  • New Topic