Win a copy of Terraform in Action this week in the Cloud forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Sybex 816 (a batch of) possible errata

 
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Note: The list below refers to the online version of the book.
Seems that for the online version the page numbers are different than in the errata

1. In some places the varargs' three dots ... are replaced by the ellipsis
Example: Chapter 1., Review Questions, question 9.  (p. 139) or question 24. (p. 150)
 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
2. Chapter 1., Review Questions, Question 16. (p. 145)
A typo in option D. (4.)

Tranport

should be:

Transport

 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
3. Chapter 2., Protecting Arguments with @SafeVarargs. It is written

We can remove both compiler warnings by adding the @SafeVarargs to line 4


should be:

We can remove both compiler warnings by adding the @SafeVarargs to line 4

 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
4. Chapter 3., Map.of() and Map.copyOf(), (p. 244-247) in the code snippet it is:

should be:
 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
5. Chapter 3., Table 3.7 (p.245-248)
Instead of: it should be:
 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
6. Chapter 3., the last code snippet in Naming Conventions for Generics. Missing letter "d" in the constructor call.

SizeLimitedCrate<Elephant, Ingeter> c1 = new SizeLimiteCrate<>(elephand, numPounds);

 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
7. Chapter 6., Table 6.5 (p. 509). A space to remove in:

java.net .http

 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
8. Chapter 6. Exploring a Top-Down Migration Strategy (p. 518).
In the 4th point it is written:

4. Repeat with the next-lowest-level project until you are done


it should be:

4. Repeat with the next-highest-level project until you are done

 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
9. Chapter 6. description before the Figure 6.10 (the last sentence, p. 524), it is written:

In this example, the zoo.tours.api and zoo.tours.reservations models make up the service since they consist of the interface and lookup functionality


should be:

In this example, the zoo.tours.api and zoo.tours.reservations modules make up the service since they consist of the interface and lookup functionality

 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
10. Chapter 6., Adding a Service Provider (p. 531)
In the TourImpl.java the "Stuffed animal"
Maybe it is ok but for the similar line in the QuickTourImpl.java the change was made (link to the commit)
 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
11. Chapter 7., Review Questions, question 20. (p. 646)
in the code snippet it is written:
<Future>?>> should be: <Future<?>>
chapter_07_q20.png
[Thumbnail for chapter_07_q20.png]
 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
12. Explanation to the question 20, Review Questions Chapter 7. (p. 1018)
In the explanation it is written:

If the submit() method had been used instead of execute(), then option C would have been correct answer (...)


That seems not true because the service variable is still not effectively final and causes a compilation error.
(see the screenshot from the 11.)
 
author & internet detective
Posts: 40847
829
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
First half:

Tomasz Kasprzyk wrote:Note: The list below refers to the online version of the book.
Seems that for the online version the page numbers are different than in the errata

1. In some places the varargs' three dots ... are replaced by the ellipsis
Example: Chapter 1., Review Questions, question 9.  (p. 139) or question 24. (p. 150)


That's a rendering issue and not something I have any control over

Tomasz Kasprzyk wrote:2. Chapter 1., Review Questions, Question 16. (p. 145)
A typo in option D. (4.)

Tranport

should be:

Transport


Agreed and added to the errata


Tomasz Kasprzyk wrote:3. Chapter 2., Protecting Arguments with @SafeVarargs. It is written

We can remove both compiler warnings by adding the @SafeVarargs to line 4


should be:

We can remove both compiler warnings by adding the @SafeVarargs to line 4


Ironically the errata report has a typo in it . But yes, we meant line 3 and I've added that to the errata

Tomasz Kasprzyk wrote:4. Chapter 3., Map.of() and Map.copyOf(), (p. 244-247) in the code snippet it is:

should be:


Agreed. This is already logged in the errata

Tomasz Kasprzyk wrote:5. Chapter 3., Table 3.7 (p.245-248)
Instead of: it should be:


Agreed. This was logged in the errata on 9/1. (So shortly before you reported it.)

Tomasz Kasprzyk wrote:6. Chapter 3., the last code snippet in Naming Conventions for Generics. Missing letter "d" in the constructor call.

SizeLimitedCrate<Elephant, Ingeter> c1 = new SizeLimiteCrate<>(elephand, numPounds);


 
Jeanne Boyarsky
author & internet detective
Posts: 40847
829
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Second half. (Also thank you for providing enough description on where these are so I can find them. I don't have the Kindle book and you are correct that the page numbers are not the same)

Tomasz Kasprzyk wrote:7. Chapter 6., Table 6.5 (p. 509). A space to remove in:

java.net .http


It's not like that in the printed book. So another Kindle thing.

Tomasz Kasprzyk wrote:8. Chapter 6. Exploring a Top-Down Migration Strategy (p. 518).
In the 4th point it is written:

4. Repeat with the next-lowest-level project until you are done


it should be:

4. Repeat with the next-highest-level project until you are done


Agreed. Added to errata

Tomasz Kasprzyk wrote:9. Chapter 6. description before the Figure 6.10 (the last sentence, p. 524), it is written:

In this example, the zoo.tours.api and zoo.tours.reservations models make up the service since they consist of the interface and lookup functionality


should be:

In this example, the zoo.tours.api and zoo.tours.reservations modules make up the service since they consist of the interface and lookup functionality


Agreed. Added to errata

Tomasz Kasprzyk wrote:10. Chapter 6., Adding a Service Provider (p. 531)
In the TourImpl.java the "Stuffed animal"
Maybe it is ok but for the similar line in the QuickTourImpl.java the change was made (link to the commit)


Yes ok. I changed them to be different so it wouldn't be confusing.

Tomasz Kasprzyk wrote:11. Chapter 7., Review Questions, question 20. (p. 646)
in the code snippet it is written:
<Future>?>> should be: <Future<?>>


That's weird. It's not like that in my printed copy. Every once in a while, Kindle has an odd rendering error. I guess this is one of those.

Tomasz Kasprzyk wrote:12. Explanation to the question 20, Review Questions Chapter 7. (p. 1018)
In the explanation it is written:

If the submit() method had been used instead of execute(), then option C would have been correct answer (...)


That seems not true because the service variable is still not effectively final and causes a compilation error.
(see the screenshot from the 11.)


Good point! Added to errata
 
Greenhorn
Posts: 10
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Chapter 3. In Table 3.7 Map methods (page 130), it is written:



it should be:


 
Marshal
Posts: 74390
334
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Welcome to the Ranch

Matus Iglarcik wrote:. . .. . .

Both are incorrect; you will find the correct method details here.
 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Matus Iglarcik wrote:Chapter 3. In Table 3.7 Map methods (page 130), it is written:



it should be:



Hi Matus, please have a look at the instructions from https://www.selikoff.net/ocp11-complete/

All known errors are listed here. To report a potential error, please create a thread at https://coderanch.com/f/24/java-programmer-OCPJP. Be sure to include “Sybex CSG 11” and the chapter and/or page number in the subject.


If you use other book than the Complete Study Guide, there are also separate pages for them:
https://www.selikoff.net/ocp11-1/
https://www.selikoff.net/ocp11-2/
Please, create your own thread with the topic relevant to the book you are using (especially adding the "Sybex CSG 11" / "Sybex 815" / "Sybex 816" according to the book).

Cheers,
Tomasz
 
Matus Iglarcik
Greenhorn
Posts: 10
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Campbell Ritchie wrote:...
Both are incorrect;
...


Signature is simplified to make it easier to understand.

Tomasz Kasprzyk wrote:...
and create your own thread
...


Thanks, i didn't notice it in the instructions.
 
Campbell Ritchie
Marshal
Posts: 74390
334
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Matus Iglarcik wrote:. . . Signature is simplified to make it easier to understand. . . .

But using straight K and V can cause a program to fail to compile.
 
Matus Iglarcik
Greenhorn
Posts: 10
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Campbell Ritchie wrote:. . . using straight K and V can cause a program to fail to compile...


You are right. Simplification used in the table can cause code not to compile. Therefore there is a note about it right before the table. The point of the table is to explain methods behavior not generics.
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Page 329, figure 6.10 - redundant arrow between locator and provider.
 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Likes 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Mateusz Wesołowski wrote:Page 329, figure 6.10 - redundant arrow between locator and provider.


Hi Mateusz, please have a look at the instructions from https://www.selikoff.net/ocp11-complete/

All known errors are listed here. To report a potential error, please create a thread at https://coderanch.com/f/24/java-programmer-OCPJP. Be sure to include “Sybex CSG 11” and the chapter and/or page number in the subject.


If you use other book than the Complete Study Guide, there are also separate pages for them:
https://www.selikoff.net/ocp11-1/
https://www.selikoff.net/ocp11-2/
Please, create your own thread with the topic relevant to the book you are using (especially adding the "Sybex CSG 11" / "Sybex 815" / "Sybex 816" according to the book).

Cheers,
Tomasz
 
Campbell Ritchie
Marshal
Posts: 74390
334
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
MW: welcome to the Ranch
 
Matus Iglarcik
Greenhorn
Posts: 10
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Campbell Ritchie please could you unlock my thread. I created it so I can add another errors in the future, but it is locked now.
 
Tomasz Kasprzyk
Ranch Hand
Posts: 34
5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
@Matus Iglarcik, each erratum should be added in a separate thread. It is more convenient for the authors (what I did not know creating this "batch" thread).
This thread is a counterexample of it and maybe should be closed as well
 
Matus Iglarcik
Greenhorn
Posts: 10
Eclipse IDE C++ Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
@Tomasz Kasprzyk, good to know. thanks. @Campbell Ritchie, ignore my request please.
 
Jeanne Boyarsky
author & internet detective
Posts: 40847
829
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Tomasz Kasprzyk wrote:@Matus Iglarcik, each erratum should be added in a separate thread. It is more convenient for the authors (what I did not know creating this "batch" thread).
This thread is a counterexample of it and maybe should be closed as well


It's a personal preference thing. If there's going to be discussion, one per thread is definitely helpful. If it's a collection of minor/typo type things, one thread is fine. (I do find it easier for it to be one post in the thread rather than a bunch of posts in the same thread.)
 
reply
    Bookmark Topic Watch Topic
  • New Topic