Win a copy of Mastering Corda: Blockchain for Java Developers this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Jj Roberts
  • Carey Brown
Bartenders:
  • salvin francis
  • Frits Walraven
  • Piet Souris

Exception while deploying the app [WebApp] : Invalid URL Pattern: [{0}].

 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi to all, i've centos7.5 standalone. having glasfish server 4.1. and netbeans. Wheni trid to deploy mine web application in glassfish server following error occured. :

 
Saloon Keeper
Posts: 6798
162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Seems like there was a parameter required to replace the "{0}", but it was not supplied or not available. We can't be sure, since we don't know the code.
 
rahul vishwakarma
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
code is :-

-----------------------
ClassFirstApp.java :-

------------------------
index.html :-
 
Saloon Keeper
Posts: 23000
156
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't see anything wrong there. Might be a bug in NetBeans. You might want to restart NetBeans and re-deploy the app to see if it happens again.
 
rahul vishwakarma
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i restarted netbeans 8.2:- then run but this is error :-

 
Greenhorn
Posts: 9
Android Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I always say url-pattern beginning with a slash or a star for wildcard mapping.

Thus, may be the pattern in your case should be as follows:
 
Marshal
Posts: 3349
492
Android Eclipse IDE TypeScript Redhat MicroProfile Quarkus Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Tim Moores wrote:Seems like there was a parameter required to replace the "{0}", but it was not supplied or not available. We can't be sure, since we don't know the code.


Seems like the {0} in the message was a Glassfish 4 bug which has been addressed:
    Message "Invalid Url Pattern" contains placeholder, while it obviously must contain the invalid pattern
 
Ron McLeod
Marshal
Posts: 3349
492
Android Eclipse IDE TypeScript Redhat MicroProfile Quarkus Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I wouldn't expect this to be an issue, but maybe try removing the new lines in the welcome-file element:
 
rahul vishwakarma
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks a lot Roland Mueller, you solved my problem i just put a <url-pattern>/webappPackage/ClassFirstApp</url-pattern> and deploy and problem solved.
 
Skool. Stay in. Smartness. Tiny ad:
the value of filler advertising in 2020
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic