• Post Reply Bookmark Topic Watch Topic
  • New Topic

Ant-only WSAD EAR building...  RSS feed

 
Mark Hissink Muller
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
All,
Kindly I would like to ask your help regarding a problem I have with a self-assembled EAR (using Ant), when testing under WSAD/WAS. Although I read Barry Searle's article at:
http://www7b.software.ibm.com/wsdd/library/techarticles/0203_searle/searle1.html
I would like to build the EAR-file completely detached from WSAD, with an Ant-script which automatically 'gets' from CVS, runs all the Unit-tests and if correct assembles the EAR. I've written a series of Ant-scripts which zip-up an EAR from all components, which I build separately.
(To my surprise) I've noticed that using a standard application.xml-file from another (exported) EAR doesn't do the job and gives me ClassNotFoundExceptions when starting the application. In some way a reference to the jar is missing. I suspect it might have to do with with the module_id in the application.xml which in some way doesn't match to id in the jar, but I could not find any info and I'm not 100% sure.
<module id="EjbModule_1063637237627">
<ejb>SomeEJB.jar</ejb>
</module>
Could anyone explain me what kind of issue I'm encountering and how to solve this?
Thanks for your insights.
Regards,
Mark Hissink Muller
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!