Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Websphere session bean pool size

 
Ranch Hand
Posts: 106
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear Sir,
I am setting the session bean pool size from admin console of WebSphere 5.0.
I went to : Application Servers > server1 > Process Definition >
Java Virtual Machine and then i clicked on Custom properties . Then i added the following property as follows
name : com.ibm.websphere.ejbcontainer.poolSize
value : *=30,100
I want all my session beans to be 30 by default min and 100 max default.
But the above setting is not taking into effect . The Tivoli Performance Viewer is showing the no of beans instantiated 50 . Plzz help me out if there is any other method of setting the beans pool size.
thx ,
siddharth K
 
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I think the Maximum Size of the ORB Service thread pool still set as 50. This is the default value.
Check under Application Servers > "your server name, e.g server1" > ORB Service > Thread Pool for this value.
In your case, you want to have a min of 30 and max of 100 session bean, you need to set the thread max size at least 100 or more. You should see the number of bean instances changed in the performance viewer up to whatever the max thread pool size that you set.
This thread pool is used to handle the connection between clients and the application server and also the communications among the components on the server side.
The reason you saw only 50 session bean instances created in the peformance viewer is that the ORB Service's max thread pool size is 50, at the most only 50 clients can concurrently connect to the server.
The container is smart enough not to create more than 50 instances of the bean since it makes no sense to create more beans than you can use.
Daryl
 
Steve Grant
Ranch Hand
Posts: 106
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear Sir,
That means the orb service is restricting the creation of bean instances. The default pool size of a stateless session bean is 50(min) and 500 (max) so if i increase only the size of orb service thread pool to 100 then 100 clients (max) can connect to the server . Is my undesratanding right ..Plzz correct me if i am wrong.
rgds,
siddharth k
 
Steve Grant
Ranch Hand
Posts: 106
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear sir,
I am testing my VFSFacade Ejb (stateless session ejb) which calls VFSIOService class . This class does the basic file operations like file writing to hard disk, file reading , copying , deleting.
I am calling this ejb through my JSP . I am testing my JSP with JUnitPErf which simulates nearly 500 users on client side and calls the JSP through HttpClient.I am simulating the test in such a way that each user will be uploading 3mb file through my EJB . In this way 500 users will be uploading their files with file size of 3mb for each user. Now my machine configuration on which WebSphere Application server is installed is 1GB Ram , Pentium 4 1.7GHz CPU and 40 GB Hard disk.
Sir can u plzz specify how to tune Websphere for the above test. Or should i reduce the number of users.
rgds ,
siddharth K
 
Steve Grant
Ranch Hand
Posts: 106
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear sir,
I did the following to increase the pool size n i was successful in increasing its size.
done in websphere
1 increase orb thread pool size.
2 increase web container thread pool size
3 enable servlet caching (for performance)
4 check pass by reference in Orb service (for performance)
5 increase the JVM haep size . for 1 gb make it 768Mb ram (for performance)
thx,
siddharth K
 
Climb the rope! CLIMB THE ROPE! You too tiny ad:
We need your help - Coderanch server fundraiser
https://coderanch.com/t/782867/Coderanch-server-fundraiser
reply
    Bookmark Topic Watch Topic
  • New Topic