This week's book giveaway is in the Cloud forum.
We're giving away four copies of Terraform in Action and have Scott Winkler on-line!
See this thread for details.
Win a copy of Terraform in Action this week in the Cloud forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Issue in launching the application in Microsoft Edge. Some of the ajax scripts not loading

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Issue in launching the application in Microsoft Edge. Some of the  ajax scripts not loading  at the time of page launch.

(The application still is working as expected in Internet explorer and Firefox till today.)

In analyzing the cause of the issue , found  in the logs of application that the session (A Map object fetched via  ActionContext.getContext().getSession();) is not null at the launch of the UI page but at the later stage  this session is blanked out which is  throwing Null Pointer Exception  causing the code to break, while the same code is working in Internet explorer and Firefox. This might be due to the browser clearing the session.
reply
    Bookmark Topic Watch Topic
  • New Topic