This week's book giveaway is in the Spring forum.
We're giving away four copies of Spring Boot in Practice and have Somnath Musib on-line!
See this thread for details.
Win a copy of Spring Boot in Practice this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

My wildfly system annot run after enable JMX remote

 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I want to enable JMX remote in my wildfly . So at the first step add follow to my standalone.conf file

JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.rmi.port=9000 -Dcom.sun.management.jmxremote.port=9000 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.local.only=false -Dcom.sun.management.jmxremote.authenticate=false"

but when I run wildfly with standalone.sh it cannot start service and show follow error :

 
Marshal
Posts: 76113
362
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Please avoid editing posts; please post anything new or different as a new post. I am reverting the changes.
 
Greenhorn
Posts: 29
2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
By default remote JMX is already enabled. It is configured to work over the http management interface.
So try removing the properties you added. Then read the Wildfly 13 manual on JMX Security [1] and JMX subsystem configuration [2] for some background.
Depending on the client you want to use you may need to add client dependencies. See the bundled script
bin/jconsole.[sh|bat] for the necessary jar files.
This DZone article [3] gives a good summary.


[1] https://docs.wildfly.org/13/Admin_Guide.html#jmx-security
[2] https://docs.wildfly.org/13/Admin_Guide.html#JMX
[3] https://dzone.com/articles/remote-jmx-access-wildfly-or
 
reply
    Bookmark Topic Watch Topic
  • New Topic