This week's book giveaway is in the Other Languages forum.
We're giving away four copies of Functional Reactive Programming and have Stephen Blackheath and Anthony Jones on-line!
See this thread for details.
Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

com .ibm. ws. exception. ConfigurationError when testing Portlets

 
Sami Kent
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there, I'm new to Websphere Portal. So I was working on my HelloWorld Portlet in the Websphere Studio Site Developer. I followed the instruction of the documentation step by step, but when I tried to run my first Portal application, I got this message:

************ Start Display Current Environment ************
WebSphere Platform 5.0 [BASE 5.0.0 s0245.03] running with process name localhost\localhost\server1 and process id 1604
Host Operating System is Windows XP, version 5.1
Java version = J2RE 1.3.1 IBM Windows 32 build cn131-20021107 (JIT enabled: jitc), Java Compiler = jitc, Java VM name = Classic VM
was.install.root = C:\IBM\WebSphereStudio\runtimes\base_v5
user.install.root = C:\IBM\WebSphereStudio\runtimes\base_v5
Java Home = C:\IBM\WebSphereStudio\runtimes\base_v5\java\jre
ws.ext.dirs = C:\IBM\WebSphereStudio\runtimes\base_v5/java/lib;C:\IBM\WebSphereStudio\runtimes\base_v5/classes;C:\IBM\WebSphereStudio\runtimes\base_v5/classes;C:\IBM\WebSphereStudio\runtimes\base_v5/lib;C:\IBM\WebSphereStudio\runtimes\base_v5/lib/ext;C:\IBM\WebSphereStudio\runtimes\base_v5/web/help;C:\IBM\WebSphereStudio\runtimes\base_v5/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;C:/IBM/SQLLIB/java/db2java.zip;C:/IBM/WebSphereStudio/wstools/eclipse/plugins/com.ibm.etools.webservice_5.0.2/runtime/ worf.jar
Classpath = C:\IBM\WebSphereStudio\runtimes\base_v5/properties;C:\IBM\WebSphereStudio\runtimes\base_v5/properties;C:\IBM\WebSphereStudio\runtimes\base_v5/lib/bootstrap.jar;C:\IBM\WebSphereStudio\runtimes\base_v5/lib/j2ee.jar;C:\IBM\WebSphereStudio\runtimes\base_v5/lib/lmproxy.jar;C:/IBM/WebSphereStudio/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.0.2/runtime/wteServers.jar;C:/IBM/WebSphereStudio/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.0.2/runtime/wasToolsCommon.jar
Java Library path = C:\IBM\WebSphereStudio\runtimes\base_v5/bin;C:\IBM\WebSphereStudio\runtimes\base_v5/java/bin;C:\IBM\WebSphereStudio\runtimes\base_v5/java/jre/bin;C:\IBM\WebSphereStudio\eclipse\jre\bin;.;C:\WINDOWS\System32;C:\WINDOWS;C:\jdk1.3.1_12\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\IBM\SQLLIB\BIN;C:\IBM\SQLLIB\FUNCTION;C:\lotus\notes
************* End Display Current Environment *************
[6/22/04 12:00:02:969 EDT] 5fddd383 ManagerAdmin I TRAS0017I: The startup trace state is *=all=disabled.
[6/22/04 12:00:03:609 EDT] 5fddd383 AdminInitiali A ADMN0015I: AdminService initialized
[6/22/04 12:00:04:781 EDT] 5fddd383 WsServer E WSVR0003E: Server server1 failed to start
com.ibm.ws.exception.ConfigurationError
at com.ibm.ws.runtime.component.MultibrokerDomainImpl.initialize(MultibrokerDomainImpl.java:79)
at com.ibm.ws.runtime.component.ContainerImpl.initializeComponent(ContainerImpl.java:507)
at com.ibm.ws.runtime.component.ContainerImpl.initializeComponents(ContainerImpl.java:420)
at com.ibm.ws.runtime.component.ServerImpl.initialize(ServerImpl.java:95)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:126)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:232)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)
at com.ibm.etools.websphere.tools.runner.api.ServerRunnerV5$1.run(ServerRunnerV5.java:97)
---- Begin backtrace for nested exception
java.lang.NoSuchMethodError: com.ibm.ws.runtime.service.ConfigRoot: method getResource(ILjava/lang/String Lorg/eclipse/emf/ecore/resource/Resource; not found
at com.ibm.ws.runtime.component.MultibrokerDomainImpl.initialize(MultibrokerDomainImpl.java:72)
at com.ibm.ws.runtime.component.ContainerImpl.initializeComponent(ContainerImpl.java:507)
at com.ibm.ws.runtime.component.ContainerImpl.initializeComponents(ContainerImpl.java:420)
at com.ibm.ws.runtime.component.ServerImpl.initialize(ServerImpl.java:95)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:126)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:232)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)
at com.ibm.etools.websphere.tools.runner.api.ServerRunnerV5$1.run(ServerRunnerV5.java:97)

[6/22/04 12:00:04:844 EDT] 5fddd383 WsServer E WSVR0009E: Error occurred during startup

I don't have any idea about it. The only thing I'm wondering is if the installation of WebSphere Studio Site Developer requires fixed IP address of local machine. Because I know this is a requirement for Websphere Portal and since there's a rudimentary built-in Portal Server in WSSD to enable testing and debugging of Portal applications.

Anybody can help? Thank you in advance.
 
Gunther Verhemeldonck
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've just installed Portal server out of the box (includes WAS fp5.01).
After successfully installing FixPak 2 for Portal Server I receive a similar error:

[16/07/04 11:07:57:625 CEST] 4d04feac WsServer E WSVR0009E: Error occurred during startup
java.lang.NoSuchMethodError: com.ibm.ws.runtime.service.ConfigRoot: method getResource(ILjava/lang/String Lcom/ibm/etools/emf/resource/Resource; not found
at com.ibm.ws.wccm.services.pme.metadata.impl.PMEServerConfigLocator.initialize(PMEServerConfigLocator.java:45)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:75)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:225)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:94)

This is my first experience in a fixpack crashing the server.
AnyBody any ideas ???
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic