Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JAAS Kerberos login on WebSphere

David Tsai
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I'm attempting JAAS login on WebSphere using Kerberos.
Running my code as a standalone Java application, my program runs without errors. My login.conf file is

However, when I tried running my code as a web service, I run into trouble. I've tried testing new login module configurations both in the login.conf file and in administrative console; the ones I've tested include:

1) required;
2) required delegate =;
3) required delegate =;

None of them seem to work. Note that I have changed my code so that it is compliant with WebSphere:

My code always crashes on the last line, usually with a Preauthentification Failed error. I'm thinking that perhaps by doing doing WSLogin/WSCallbackHandlerImpl/WSSubject that somehow I am no longer authenticating with kerberos but am instead authenticating with something in Websphere.

Any ideas on how I fix this would be greatly appreciated.
[ August 25, 2004: Message edited by: David Tsai ]
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic