Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Error while accessing DB2 thru WSAD..yes it is the same problem. No..I cudnt solve it

 
Mugz Yash
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello-
An amateur developer, I am struggling to understand why I am getting this error. I saw the responses and tried the suggestions but it didnt help. Maybe I am not doing it the right way. Can anyone be more specific in how I can change 1.3 to 1.2 OR 4.0 to 5.0? And why is it that this change needs to be made?
The error again is:
-------------------------------------------------------------------
com.ibm.websphere.naming.CannotInstantiateObjectException: Exception occurred while the JNDI NamingManager was processing a javax.naming.Reference object. [Root exception is javax.naming.NamingException: Attempted to use a 4.0 DataSource from a 2.3 (or higher) servlet. Invalid configuration.]
-------------------------------------------------------------------

Thank you in advance.
~Mugz
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34974
379
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Mugz,
Welcome to JavaRanch!

What version of WSAD are you on?
 
Mugz Yash
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using WSAD 5.0. And I need to correct my question. I am having problem connecting to Oracle 8i.

Thanks.
 
lorco M
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, In WSAD 5.0 you can use two kinds of DataSource, if you work with a 2.3 servlet you can't work with 4.0 Datasource.
You can change it in your server config, take 5.0 one
 
Mugz Yash
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
All the EJBs that we are using are 1.1 spec and so we have to use the 4.0 DataSource. Is there another option?

Thanks..
mugz
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34974
379
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Mugz,
It sounds like you are trying to use two different versions of the J2EE spec. EJB 1.1 is fairly old which Servlets 2.3 is more modern.

What version of J2EE would your EAR be? I don't think you can do this.
 
Mugz Yash
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The version of EAR is 1.3
~thx.
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34974
379
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Mugz,
And J2EE 1.3 supports EJB 2.0. I'm surprised you have gotten as far as you did with this configuration.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic