• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Can't debug jsp

 
Chris Wang
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I am using wsad 5.1.1 with tomcat test environment web server.
I set up some break points in servlets and jsp files.
And then start web server in debug mode.

Run the application and breakpoints in servlets can be stopped.
But breakpoints in jsp will never be stopped. -- Why?
I should mention that I really put the breakpoints in the right place of a jsp file, that's at scriptlet code.

Any help is highly appreciated!

Chris
 
Jesus Angeles
Ranch Hand
Posts: 2068
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
when you ran the application, did it run on the server that you started on debug mode?

you can check by looking at the server list, if you started the server on debug mode, and ran your application on it correctly, then there should only be one server running, the one in debug mode. if there are 2, then your application might have run on the other one, not the one in debug mode. if so, you can make sure it runs on the right server, i believe, by associating the applicaiton with that specific server, ..try right click on server and choose 'Add' , and choose the application.

thats the only thing i can think that would cause that
 
Chris Wang
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for your reply.
For sure I ran my app on debug mode of tomcat 4.1 test environment.
In the same run I put some breakpoints both in java file and jsp file, the execution only stoppted at a breakpoint in java file, but never the one in jsp file. From this we can say the debugging is kind of running, it works in java file but not jsp file. My question was why debugging does not work on jsp file.

Chris
 
Joe Boxer
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am having a similar problem on �some� JSP�s. The debugger stops on e.g. abc.jsp but not on xyz.jsp. It stops correctly on my colleague�s machine!

Is anyone aware of any temp files for the debugger to delete?

Cheers
Joe
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic