Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WASv5.1.1.6: JMX NotificationListener not working for ListenerPort events?

 
Wim Praet
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

since this thread seems to be dead, I repeat my question here.

I have written following piece of code that adds a JMX NotificationListener for events from an MBean that represents a ListenerPort in Websphere v5.1 (I have v5.1.1.6 installed), following the example code from here :



However, when the ListenerPort is started or stopped, I don't get any notifications!

I tried to add notification listeners for other kind of events, like stopping or starting an application under WASv5.1 and those work fine.

Could it be that there is a bug in the JMX notification mechanism of ListenerPort MBeans?

In the meanwhile I ended up writing a scheduled Quartz Job that interrogates the 'started' attributed of the ListenerPort every couple of seconds to check if it is still up, and restart it in case it is stopped. However, this is not the preferred way of doing things I guess...

Thanks for any help on this one,
Wim.
 
Martin Villafane
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I know this post is kind of old, but I'm experiencing exactly the same problem. Did you find another way to solve your problem? (apart from polling the Listener Port attribute).

Thanks
 
Paul Clapham
Sheriff
Posts: 21416
33
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Martin Java wrote:I know this post is kind of old...


Actually it's not just "kind of old". I think hoping that the original poster, who hasn't posted here for over four years, is a vain hope.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic