Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Generating Crash Dump in WSAD

 
krishna
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI evryone

I am facing some problems in Web Studio Application Developer 5.1.2, when I start my server in debug mode.., the system generates a Crash Dump, and the server stops..

Is there any way to fix this problem in WSAD(Web Studio Application Developer)?
 
Scott Selikoff
author
Saloon Keeper
Posts: 4020
18
Eclipse IDE Flex Google Web Toolkit
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WAS server debug mode is sometimes very unstable. There's no simple fix since your description was pretty vague but you might want to try installing any IBM fix packs for your particular version of both WSAD/WAS.

Also, try starting your server in debug mode outside of WSAD (using WSADMIN) then connecting with WSAD using a Remote Java Application call supported in the WSAD debug menu.
 
krishna
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Scott
I dont have the admin rights for the system...i jus have wsad Installed in my PC at my work place....this sounds complicated to me..
 
Scott Selikoff
author
Saloon Keeper
Posts: 4020
18
Eclipse IDE Flex Google Web Toolkit
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How can you 'start the server in debug mode' without admin rights to the server? You lost me.
 
krishna
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not able to find the IBM fix packs for the crash dump.

Let me know the source for any patch available.
 
Marc Peabody
pie sneak
Sheriff
Posts: 4727
Mac Ruby VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We once had something similar where there were too many tags in a jsp for debug mode to handle. It was weird. We removed some of the tags to make it work.
 
Patrick Java
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have exactly the same problem when running no debug mode.

Here it is what I got.

Unhandled exception
Type=GPF vmState=0xffffffff
Target=20030915 (Windows XP 5.1 build 2600 Service Pack 1 x86)
ExceptionCode=0xc0000005 ExceptionAddress=0x1060b16b ContextFlags=0x0001003f
Handler1=0x111016c0 Handler2=0x10019730
Module=C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\runtimes\base_v51\java\jre\bin\J9GC21.dll
Module_base_address=0x10600000
Offset_in_DLL=0x0000b16b
EDI=0x000a0c1c ESI=0x09ad2554 EAX=0x080246f8
EBX=0x00099a10 ECX=0x00099aac EDX=0x00000000
EBP=0x000cbf00 ESP=0x0481f9bc EIP=0x1060b16b

Generating crash dump: C:\Documents and Settings\patrick\j9.dmp

Thread: Servlet.Engine.Transports : 0 (priority 5) (daemon) (LOCATION OF ......
 
Prasanna l reddy
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I got exactly same issue when I run the application in debug mode.

Solution :

In WAS admin console >servers >application server. Then click on Server1 > Process Defintition>Java Virtual Machine. Here you see all general properties and increase Initial Heap Size =256 and Maximum Heap Size = 512. THis fix the above problem.

Url for local host: http://localhost:7090/admin/secure/logon.do ( note: port number may be different depends on your configuration)

Thanks.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic