Win a copy of Spring Boot in Practice this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Tim Cooke
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Liutauras Vilda
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Al Hobbs
  • Carey Brown
Bartenders:
  • Piet Souris
  • Mikalai Zaikin
  • Himai Minh

Urgent... IBM WAS 5.1 MDB Listener?????

 
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
We developed a client interface that receives trade related messages from the server at the speed of 75 messages per second. Once our client interface receives messages, it sends those messages to various queues
(IBM Websphere MQ 5.3 with CSD011) according to the message type.

Furthur MDBs in our Enterprise application picks those messages and calls business process which will return messages' validity.

************
The problem
************
I set the 'Maximum Messages' property of a listener to 150, and if all the messages are valid (as per business process), it works fine and finally I have very few backlogs in the queues.

If some messages are invalid message I set that particular message as rollbackonly. As per the IBM WAS Specification, it will pick 150 messages per session, if anything goes wrong in the middle, it will rollback all. (As I know).

If I set 'Maximum Messages' as 1, and if some messages are invalid it goes to DEAD_LETTER_QUEUES (as per my specification) all went right. But I have huge backlog at the queues that tooks several minutes to clear ie; to process. How can I tune IBM WAS to process messages quickly? (so that I can get the same performance if I set the Max message value to 150) I have 'Maximum Sessions' 1 for the listener. I cannot increase the session value to morethan 1 since I need messaging order.
 
author
Posts: 4323
39
jQuery Eclipse IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Someone should definitely move this to the Websphere forums...

To summerize your problem (if I read all that correctly) you want to force WAS to read messages quickly? There may be a setting for this, but I'm not sure why'd you want to use it. Messages are a-synchronous in nature and never guarenteed to be delivered right away. If you need an instant message you should look into sychronous solutions.
 
Wanderer
Posts: 18671
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
And it's off to the WebSphere forum we go...
 
Ranch Hand
Posts: 82
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
setting the maxsessions to one does just what it says. Basically it only allows one message at a time to processed. This is often used for systems that have a business requireent for the messages to always processed in a strict order. When you specified 150 you are allowing the container to create up tp 150 connections to to process messages concurrently.
 
reply
    Bookmark Topic Watch Topic
  • New Topic