Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
  • Mikalai Zaikin

Websphere portal admin console

Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I created a new WebApp and want to deploy it on WebSphere_Portal(intending to run the model standalone on the Websphere Portal Server).

I deployed the ear file via the Websphere admin console (http://<machinename>:9090/admin/), using Applications..Install New Application.., choosing in Step 3 to map the module to the Websphere_Portal server. I completed the deployment, it said it was successful, I saved the changes to Master Configuration in the admin console.

But I try to start the Enterprise App that I just deployed, and there's an "unavailable" icon next to it, even though the EAR is showing up in the installed applications directory. The message in the Messages(s) window says "The application can not be started on server WebSphere_Portal. Make sure the server is started." (And it is)
Later on,I found out that I must run that application from the portal server admin console not the WAS admin console.
When I tried accessing the portal admin console however I couldn't. I added the property:
in but I still get HTTP 404 Not Found on:

I really need to deploy an EAR file on the WebSphere_Portal. Can anyone help me?
How can I enable the portal admin console? How do I get to it to run my application?

Thanks in advance.
Ranch Hand
Posts: 173
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Nevine, did you attach the project to the EAR? If so, then are you doing this via your localhost setup in WSAD? I discovered that unless someone figured out a way to do this, you cannot get a process to work independently in the admin console unless you installed WAS and are using the admin console via the WAS. I've never been able to successfully deploy anything otherwise and IBM refuses to respond to my emails requesting help. If you are using localhost on your WSAD, right-click on the server name in Server Configurations (make sure you are using the Server view if you don't see that), select Add and Remove Projects, then add the new project that way and it should work. Please forgive me if you already know all of this and are already trying to deploy to WAS. If you have already done all of this and are trying to deploy via WAS, then you need to first check out IBM's website to see if there's anything specific to your problem or contact IBM directly, in which case, I wish you much luck.
Posts: 12
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Nevine.,

As per ur note, I guess ur WebSphere_Portal not started.
thats y
http://localhost:9091/admin not up, What we can do start the WebSphre_Portal --> cd to WebSphere/AppServer/bin on cmd line
startServer.bat WebSphere_Portal, then Portal Admin console up

Regarding this , if u can get any results please let me know,letus work out

The moustache of a titan! The ad of a flea:
We need your help - Coderanch server fundraiser
    Bookmark Topic Watch Topic
  • New Topic