This week's book giveaways are in the Jython/Python and Object-Oriented programming forums.
We're giving away four copies each of Machine Learning for Business: Using Amazon SageMaker and Jupyter and Object Design Style Guide and have the authors on-line!
See this thread and this one for details.
Win a copy of Machine Learning for Business: Using Amazon SageMaker and JupyterE this week in the Jython/Python forum
or Object Design Style Guide in the Object-Oriented programming forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
  • Knute Snortum
Sheriffs:
  • Liutauras Vilda
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Joe Ess
  • salvin francis
  • fred rosenberger

what should be the compiler complicance level?

 
Ranch Hand
Posts: 365
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We are using JDK version 1.4

By default we found that the compiler complicance level under preferences is 1.3.

1. What should decide whether we should change this to 1.4 or not?
2. How will the minor versions of JDK affect this setting of 1.3 or 1.4?

Regards,
Tina
 
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you are using WebSphere 5.1.2 or lower, then, like me, your pretty much stuffed because it only provides support up to JDK 1.3. I suppose you could try and hack 1.4 compliance into it.....

Later versions of the WebSphere (6?) I believe support JDK 1.4.

So, if you're using 1.4, I suppose the key decider is what benefits it'll provide you with: I think for myself the getTimeinMillisecs() method of the Calendar class was reason enough for me to weep at the shortfalls of WebSphere 5.1.2, plus there was some a getGeneratedKeys() methof PreparedStatement that returned all the genrated primary keys of an insert, which when I saw that I thought "nice!" and then cursed the IBM corporation for not supporting it!

hope this helps!
 
Tina Desai
Ranch Hand
Posts: 365
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
umm.. sorry to say but I got a bit confused.
I do not want to do a choice between 1.3 or 1.4 based on what methods I need. I know that we need to use JDK1.4

It would be more appropriate to ask-
What does setting a particular compiler compliance level mean?

If I keep JRE 1.4 on my machine and point the 'installed JRE' from the preferences, wont it mean that I am using JDK1.4? And no other check is required?

Why do we need to set the compiler compliance level?

Thank you in advance!

Regards,
Tina
 
Alana Sparx
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ahhhh!

Sorry about that.

OK, you can set the compiler complioance level to *ANY* JDK, as long as you have the JDK installed on your development machine and ultimately on the deployed server. When developing your application this will allow you build against that JDK. Now this should be fine until you get to JDK 1.4.

Note that all this relates to *building* your application. If you set the JDK compilet compliance level at JDK 1.4, you can build and compile fine. The minute you [i]deploy[i] this on a WebSphere App server 5.1.2 (or lower), and use any functionality provided by JSK 1.4 and not present in JDK 1.3, your application will crash on the server, because the runtime environment of the App Server only supports up to JDK 1.3
 
Alana Sparx
Ranch Hand
Posts: 121
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In a nutshell, if you develop an appication using JDK 1.4, and utilise the 1.4 specific additions, you will be unable to deploy this on WebSphere 5.1.2. As I said previously, you'll need WebSphere 6 (which I believe is called RAD).
 
Ranch Hand
Posts: 286
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If your target deploy environment is WAS 5.1 or 6.0, then you should use JRE 1.4 in your WSAD 5.1 (for WAS 5.1) or RAD (for WAS 5.1/6.0). If the target deploy environment is WAS 5.0, then you should use JRE 1.3.

For which version of Java is supported by WAS, please check the prereq page for the corresponding version.

http://www-1.ibm.com/support/docview.wss?rs=180&uid=swg27006921
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We are using WSAD 5.0 and the application which we want to deploy has been developed in JDK1.5 using generics and various annotations of JDK 1.5. Please tell me the way to make WSAD 5.0 as JDK1.5 compliance.

If anybody has done it, please let me know the steps to do that.
 
author & internet detective
Posts: 39789
797
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Inderjeet,
Please don't post the same thing in multiple threads. See my reply to your other post for the answer.
 
No prison can hold Chairface Chippendale. And on a totally different topic ... my stuff:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!