• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

How to create a fresh project from CVS

 
Ranch Hand
Posts: 77
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
WSAD 5.1, 1.4.2 JVM, recent CVS.

I created a working Struts project, put it in CVS. updates/commits work fine.

Now, I want to deploy the code base on another developer's machine where this project has never been.

I can't see how to import from CVS as a project.

How do I do this without hackery?
[ October 24, 2006: Message edited by: Tony Smith ]
 
Marshal
Posts: 27214
87
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I don't have WSAD 5.1 on my machine any more, I'm using RAD 6.0 now. In that product you do this: open a CVS Repository Exploring perspective, find the project under HEAD or a branch or wherever, right-click, choose Check Out.

However I upgraded because of 5.1's inadequacy with respect to CVS, so this may not work for you. Or it may have been different in 5.1, I don't remember.
 
Tony Smith
Ranch Hand
Posts: 77
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You are correct that it is different in 5.1.

I'm using 5.1 in order to maintain consistency with our Websphere 5.1 production server.
 
Paul Clapham
Marshal
Posts: 27214
87
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have a 5.1 Websphere server too. As far as I can see the compatibility is taken care of by keeping your projects at the appropriate J2EE and servlet level, so that didn't concern me.

However installing RAD 6.0 is going to take you a couple of days if you include installing all the patches and upgrades, so I wouldn't suggest that as the cure for your problem until you reach a sufficient level of desperation.
 
Slime does not pay. Always keep your tiny ad dry.
Free, earth friendly heat - from the CodeRanch trailboss
https://www.kickstarter.com/projects/paulwheaton/free-heat
reply
    Bookmark Topic Watch Topic
  • New Topic