Forums Register Login
RAD6/WAS6 Uninstall?
I have recently attempted to migrate from a WSAD5.1 environment to RAD6.

I installed RAD6.. created a workspace with all my projects from cvs and all looked good.

Then I went about trying to configure a WAS6 server to run stuff on with security enabled - and from there on its all gone a bit pear-shaped!

My server woudlnt start - so I couldnt get to the admin console any more, so I couldnt fix the configuration problems that were preventing the ersver from starting (Fantastic Catch22 situation!).
I decided the only reasonably approach was to attempt an uninstall and re-install.

1stly I attemtped to uninstall and re-install just the WAS6 server leaving the RAD6 installation alone - but the uninstall failed and re-instal left me with all kinds of errors so I went for the full uninstall.

My attempt to fully uninstall failed (apparently the path to some files IN THE DEFAULT INSTALLED LOCATION was too long to remove).. so I manually deleted the directories under "Program Files/IBM/Rational/.."

After re-installing again I still get errors saying the WAS6 wont run correctly...

WHAT DO I HAVE TO DO? Am I facing a complete laptop rebuild just to reconfigure a server? Have other people faced this? Is there a way to uninstall so I can start from scratch without going the full OS re-install?

..as you can tell after about 14 hours of installing, patching and uninstalling I'm about to go on a gun-totting rampage across the country unless I find some kind of hope soon!!
Which OS you are using?
1] You can install WSAD6 server on the same machine again by giving different path. No need to uninstall. Leave all things intact & try to install in a new directory. If you are using windows as your OS, try different drive.
2] Also check your system date is correct.
3] Which jdk version installed on your machine (if any)? Though application servers normally ignores the enironment variables (path,classparh,JAVA_HOME) , still I will suggest to check , whether there is jdk1.2 or older version present in environment variables . If there is any, please try by removing it.
4] After installation , still problem persists , please post the complete error message .
5] Also if you are not able to resolve problem, install the app server 6 again by chosing it as windows service.
One more thing, after installation still there is problem & if your OS is windows, then delete the registry entry HKEY_LOCAL_MACHINE\SOFTWARE\IBM\WebSphere Application Server\
& then reinstall the server again.
Hi Adrian,

When things go wrong with global security and you can't reach admin console
as you told above, you can turn security off using wsadmin utility;

then,on interactive command line,

then restart your server again and global security is turned off and admin console is reachable again.

It seems to be a little late for you this time, but may save you from some headache next time

Wishing you patience and good luck
Kurtcebe Eroglu
Heres the
C:\Program Files\IBM\Rational\SDP\6.0\logs\was_v6_out.log from my install attempt...

I'm really not keen to install WAS into a different directory - that is asking for problems in the future

I've followed everything in here:

..and am now on my last attempt to uninstall-reinstall...

If this doesnt work I'm about to go off and yell at someone from IBM support....
Kurt - your hint is a lifesaver!

Every time I enable security the thing falls over in a screaming heap.. but at least I can recover each time now..

I've tried authenticating using LDAP or with a local OS account and either way I get the same error when the server tries to start..

I found a couple of updates for WAS from 6.0.0 to 6.0.2 - but the updaters dont run saying they cant find a suitable JVM. I tried pointing them at my 1.5 JVM and they fail. I downloaded a 1.4 JVM and pointed them at that - and still they fail...


I've tried:
update.exe -is:javahome %JAVA_HOME_DIR%
update.exe -is:javahome C:\Program Files\Java\jre1.5.0_10\bin
update.exe -is:javahome C:\Program Files\Java\j2re1.4.2_13\bin
update.exe -is:javahome C:\Program Files\Java\j2re1.4.2_13
..all with the same result...
I dont even know if these patches once applied will make ANY difference to my underlying security problem!
[ February 08, 2007: Message edited by: Adrian Wallace ]
Hi Adrian,

I remember similar errors on a WAS ND setup. Problem was that after global
security had been enabled, synchronization between deployment manager
profile and production profiles somehow failed. Solution was to shutdown
all nodeagent processes, issue a manual synchNode command, restart
nodeagents again.

I work on AIX boxes and don't have experience on WAS running on Windows
but one thing about your updater problem may be, it is searching for an
IBM JVM and you are pointing to another (SUN perhaps) jvm.

Just for reference for anyone else experiencing this I found this pieceof gold to get my security working:


(I still havent got the updater working - but hey - everything else seems ok - so I'm not too worried!

in order to get the update installer working, try placing the fixpak files into the RAD/RSA updateinstaller subdirectory of the server, eg:

<RAD/RSA install dir>\runtimes\base_v6\updateinstaller

so you should end up with the update.exe to be:

<RAD/RSA install dir>\runtimes\base_v6\updateinstaller\update.exe

Now if you run it from there, it "knows" how to find the JRE of the server and installation should proceed ok.

Thanks - I'd actually got the updater working. The reason it didnt work before is I had the wrong files given to me by a colleague! Once I sourced the correct stuff for the updater it all worked 'out of the box'
Wink, wink, nudge, nudge, say no more ... https://richsoil.com/cards

This thread has been viewed 6228 times.

All times above are in ranch (not your local) time.
The current ranch time is
Jan 19, 2018 12:46:48.