• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Upgrading JDK version to JDK 1.4.2_12 in WSAD 5.1.2 including server

vasishta sahasra
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This job should not only include compiler and JRE migration but also server migration. I am able upgade the compiler and Jre but when i run the test server it is pointing same java home :
please see the envroment log:

************ Start Display Current Environment ************
WebSphere Platform 5.1 [BASE cf30412.02] [JDK 1.4.1 b0344.02] running with process name localhost\localhost\server1 and process id 3004
Host Operating System is Windows XP, version 5.1 build 2600 Service Pack 2
Java version = J2RE 1.4.1 IBM J9 build 20030915 (JIT enabled), Java Compiler = j9jit21, Java VM name = IBM J9SE VM
was.install.root = C:\WSAD 5.1.2\runtimes\base_v51
user.install.root = C:\WSAD 5.1.2\runtimes\base_v51
Java Home = C:\WSAD 5.1.2\runtimes\base_v51\java\jre
ws.ext.dirs = C:\WSAD 5.1.2\runtimes\base_v51/java/lib;C:\WSAD 5.1.2\runtimes\base_v51/classes;C:\WSAD 5.1.2\runtimes\base_v51/classes;C:\WSAD 5.1.2\runtimes\base_v51/lib;C:\WSAD 5.1.2\runtimes\base_v51/lib/ext;C:\WSAD 5.1.2\runtimes\base_v51/web/help;C:\WSAD 5.1.2\runtimes\base_v51/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;C:/Program Files/SQLLIB/java/db2java.zip;C:/WSAD 5.1.2/wstools/eclipse/plugins/com.ibm.etools.webservice_5.1.2/runtime/worf.jar
Classpath = C:\WSAD 5.1.2\runtimes\base_v51/properties;C:\WSAD 5.1.2\runtimes\base_v51/properties;C:\WSAD 5.1.2\runtimes\base_v51/lib/bootstrap.jar;C:\WSAD 5.1.2\runtimes\base_v51/lib/j2ee.jar;C:\WSAD 5.1.2\runtimes\base_v51/lib/lmproxy.jar;C:\WSAD 5.1.2\runtimes\base_v51/lib/urlprotocols.jar;C:\Program Files\IBM\SQLLIB\java\db2java.zip;C:/WSAD 5.1.2/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.1.1.1/runtime/wteServers.jar;C:/WSAD 5.1.2/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.1.1.1/runtime/wasToolsCommon.jar
Java Library path = C:\WSAD 5.1.2\runtimes\base_v51/bin;C:\WSAD 5.1.2\runtimes\base_v51/java/bin;C:\WSAD 5.1.2\runtimes\base_v51/java/jre/bin;C:\WSAD 5.1.2\eclipse\jre\bin;.;C:\WSAD 5.1.2\eclipse\jre\bin;C:\WINDOWS\SYSTEM32;C:\WINDOWS;C:\PVCS\DIMENS~1\7.2\PROG;C:\oracle\ora92\bin;C:\Program Files\Oracle\jre\1.3.1\bin;C:\Program Files\Oracle\jre\1.1.8\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32\wbem;C:\WINDOWS\SYSTEM32;C:\WINDOWS;C:\PVCS\DIMENS~1\7.2\PROG;C:\oracle\ora92\bin;C:\Program Files\Oracle\jre\1.3.1\bin;C:\Program Files\Oracle\jre\1.1.8\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32\wbem;C:\WINDOWS\SYSTEM32;C:\WINDOWS;C:\PVCS\DIMENS~1\7.2\PROG;C:\oracle\ora92\bin;C:\Program Files\Oracle\jre\1.3.1\bin;C:\Program Files\Oracle\jre\1.1.8\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32\wbem;C:\WINDOWS\System32;C:\apache-ant-1.6.5\bin;C:\j2sdk1.4.2_12\bin;;C:\Program Files\SQLLIB\bin;C:\Program Files\SQLLIB\java;C:\apache-ant-1.6.5\bin;C:\j2sdk1.4.2_12\bin;;C:\Program Files\SQLLIB\bin;C:\Program Files\SQLLIB\java;C:\apache-ant-1.6.5\bin;C:\j2sdk1.4.2_12\bin;;C:\Program Files\SQLLIB\bin;C:\Program Files\SQLLIB\java;;c:\iefcmw32;c:\cool\gen;C:\apache-ant-1.6.5\bin
************* End Display Current Environment *************

Steps i used to change WSAD5.1.2 environment to point jdk 1.4.2_12

1) Open Windows Compiler Java Preferences
Select the Compliance and Classifies tab, and set the Compiler
compliance level to 1.4--I want this to 1.4.2_12

2) Then select the Java Installed JREs
Select the last checkbox in the list of Installed JREs. (Selected VM's
location should be C:\jdk 1.4.2_12\jre

Then Click �OK'

Preferences and select the J2EE
3) Open the Windows tab.
On the Server Targeting Support Pane, Select the Enable server
targeting Support radio button.

Then Click �Apply' and �OK'

4) Change the workspace to J2EE perspective.
Under Enterprise Applications, right click your EAR file and select
�TargetServer Modify

5) On Modify Target Server Window, select the Windows Application
Server v5.1( i selected this because this is the latest version) from the dropdown and click �OK'

6) Under Enterprise Applications, right click your EAR file and
select TargetServer Synchronize.

7) And Click �OK'

8) Delete the existing deployed code in your EJB projects, which are
under the EAR project ( I wanted to delete these but I could not how can I..?)

9) Rebuild all the projects and Re-Generate the RMIC code for EJB
10) Start the server. This shouldn't give any errors while starting

This did not solve the problem

Can you guys plese suggest somthing ,

this all reflect the DST of 2007 which should be tested on my build box against the JDK 1.4.2_12 as this version is on our Prodution Application servers.

Please don't give any advise like " you can apply the path to WSAD given IBM" I don't want this I want to run Test server with JDK 1.4.2_12

Thanks in very advanvce

Jeanne Boyarsky
author & internet detective
Posts: 35090
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
this all reflect the DST of 2007 which should be tested on my build box against the JDK 1.4.2_12 as this version is on our Prodution Application servers.

Is your production app server WAS 5? Note that IBM doesn't support Java 1.4 on WSAD/WAS 5. You need to upgrade to 6 for Java 1.4.

IBM does have a Java 1.3 patch for daylight savings time. You can find it at developerworks. This patch would work with WSAD 5.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic