This week's book giveaway is in the Artificial Intelligence and Machine Learning forum.
We're giving away four copies of Succeeding with AI and have Veljko Krunic on-line!
See this thread for details.
Win a copy of Succeeding with AI this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
  • Junilu Lacar
Sheriffs:
  • Tim Cooke
  • Jeanne Boyarsky
  • Knute Snortum
Saloon Keepers:
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • salvin francis
  • fred rosenberger
  • Frits Walraven

web.xml

 
Ranch Hand
Posts: 112
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I changed one line in the web.xml file, redeployed it to the websphere 5.0 server and now I get an error message when I try to visit the website.

"Error 404: No target servlet configured for uri"

I thought maybe I did something wrong or deleted something I shouldn't have in the web.xml file or application.xml file. So I reverted back to what worked and low and behold, I got the same error. I'm not sure what's wrong now because what worked yesterday is no longer working today.

I searched some forums and topics, but I'm new to websphere, so i'm not sure what the issue is. And if you've read other posts I've written recently, I am not the server admin of websphere 5.0. I can't read the errors or logs and I can't even access anything on the server. I just ftp an ear file and from there the server admins scripts are run to install, update, or delete the application. So at this point, the server admin said nothing changed, and i'm stuck.

Not sure how to fix the,

Error 404: No target servlet configured for uri

thanks.
 
author and cow tipper
Posts: 5000
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What was the change that you made? Sounds like perhaps you wiped out the Servlet mapping. Could you post the web.xml file for the J2EE/WebSphere application, without comprising your application security? Maybe then we can help to troubleshoot the web module.

-Cameron McKenzie
 
william gates
Ranch Hand
Posts: 112
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It seems to be working now, however the Login Form I've created is being completely ignored.

When i try to access the secure section, a prompt box automatically pops up rather than my jsp Form and I can type in the username and password and then forwards it to the next section or forwards it to some default websphere error page if unsuccessful.

I set the web.xml to FORM based but for whatever reason it seems to be automatically using Basic Authentication.

Here is what the web.xml file looks like with variables changed.

----
<?xml version="1.0" encoding="ISO-8859-1"?>
< !DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">;
<web-app>
<icon></icon>
<display-name>testing</display-name>
<description>testing web application</description>
< !-- <distributable><distributable> -->
<context-param>
<param-name>driverclass</param-name>
<param-value>sun.jdbc.odbc.JdbcOdbcDriver</param-value>
</context-param>
<context-param>
<param-name>jdbcURL</param-name>
<param-value>jdbc dbc b2</param-value>
</context-param>
< !-- <filter></filter> -->
< !-- <filter-mapping></filter-mapping> -->
< !-- <listener></listener> -->

<servlet>
<servlet-name>f_Sql_Center</servlet-name>
<servlet-class>test.f_Sql_Center</servlet-class>
</servlet>

<servlet>
<servlet-name>DBservlet</servlet-name>
<servlet-class>test.DBservlet</servlet-class>
</servlet>

<servlet>
<servlet-name>f_Sql_Tables</servlet-name>
<servlet-class>test.f_Sql_Bean</servlet-class>
</servlet>

<servlet-mapping>
<servlet-name>f_Sql_Center</servlet-name>
<url-pattern>/f_Sql_Center</url-pattern>
</servlet-mapping>

<servlet-mapping>
<servlet-name>f_Sql_Tables</servlet-name>
<url-pattern>/f_Sql_Tables</url-pattern>
</servlet-mapping>

<servlet-mapping>
<servlet-name>DBservlet</servlet-name>
<url-pattern>/DBservlet</url-pattern>
</servlet-mapping>

<session-config></session-config>
< !-- <mime-mapping></mime-mapping> -->

<welcome-file-list>
<welcome-file>index.jsp</welcome-file>
</welcome-file-list>

<error-page>
<error-code>403</error-code>
<location>/ErrorPage.jsp</location>
</error-page>

<taglib>
<taglib-uri>http://java.sun.com/jstl/core</taglib-uri>;
<taglib-location>/WEB-INF/tlds/c.tld</taglib-location>
</taglib>

< !-- <resource-env-ref></resource-env-ref> -->

< !-- <resource-ref><br /> <res-ref-name>jdbc/abcTest</res-ref-name><br /> <res-type>javax.sql.dataSource</res-type><br /> <res-auth>Container</res-auth><br /> <res-sharing-scope>Shareable</res-sharing-scope><br /> </resource-ref><br /> -->

<security-constraint>
<display-name>Cims Login Security</display-name>
<web-resource-collection>
<web-resource-name>Login Protected Area</web-resource-name>
< !-- Define the context-relative URL(s) to be protected -->
<url-pattern>/secure/*</url-pattern>
< !-- If you list http methods, only those methods are protected -->
</web-resource-collection>
<auth-constraint>
< !-- Anyone with one of the listed roles may access this area -->
<role-name>test</role-name>
</auth-constraint>

</security-constraint>

< !-- Login configuration uses form-based authentication -->
<login-config>
<auth-method>FORM</auth-method>
<form-login-config>
<form-login-page>/sLogin.jsp</form-login-page>
<form-error-page>/sError_Page.jsp</form-error-page>
</form-login-config>
</login-config>

< !-- <security-role></security-role> -->
< !-- <env-entry></env-entry> -->
< !-- <ejb-ref></ejb-ref> -->
< !-- <ejb-local-ref></ejb-local-ref> -->
</web-app>

Not sure why the jsp form is being completely ignored.


-----
 
Maybe he went home and went to bed. And took this tiny ad with him:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic