This week's book giveaway is in the Kotlin forum.
We're giving away four copies of Kotlin Cookbook and have Ken Kousen on-line!
See this thread for details.
Win a copy of Kotlin Cookbook this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Knute Snortum
  • Henry Wong
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Frits Walraven
  • Joe Ess
  • salvin francis

hibernate3.0 support by WSAD

 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
can anyone tell me whether hibernate3.0 is supported by any of the latest version of WSAD, so that i can run my application in WSAD test enviroment
 
Marshal
Posts: 24850
60
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, no and yes. There is no explicit "support" necessary. Hibernate is just Java code, and it does work in WSAD.
 
mahesh krishnan
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Paul,
i am using hibernate3.0 and spring2.0 for my persistence layer in WSAD 5.0.0.It is working fine during compile time, since i have configured all jar files in JAR dependency editor.But during runtime i am getting exception
"java.lang.UnsupportedClassVersionError: org/hibernate/cfg/Configuration (Unsupported major.minor version 48.0)"

Please help me to fix this issue
 
Ranch Hand
Posts: 62
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi, hibernate 3.x versions require j2ee 1.4.x which is supported only in RAD 6.x onwards. if you are running hibernate3.x on wsad 5.x, you get this excepiton as it supports only j2ee 1.3.x
 
mahesh krishnan
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
thanks for your help and suggestions.When i installed WSAD5.1.1, it's working, since it's using JRE1.4 for it's WTE.
 
The fastest and most reliable components of any system are those that are not there. Tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!