Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

what is the JSF version support by was 6.1/rad 7.0

 
Justin(lijun) wang
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
what is the JSF version support by websphere application server 6.1/rad 7.0? seems like it is still JSF 1.0. can't believe it. Can I use JSF 1.2 by just download and copy JSF 1.2 jar file to my own web application lib?
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34681
367
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Justin,
Websphere 6.1 supports JSF 1.1. I don't know about WebSpher 7.

I wouldn't expect updating the jar file to work, but you could try it to find out.
 
Oricio Ocle
Ranch Hand
Posts: 284
Debian Firefox Browser Netbeans IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Justin(lijun) wang wrote:what is the JSF version support by websphere application server 6.1/rad 7.0? seems like it is still JSF 1.0. can't believe it. Can I use JSF 1.2 by just download and copy JSF 1.2 jar file to my own web application lib?


You can, but this has two drawbacks:
- Develpment: RAD plugins will continue working with JSF 1.0
- Execution: Since JSF belongs to WAS 6.1 runtime, you will need to change class loading policy to PARENT_LAST in order to override server implementation.

Regards
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic