• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

jakarta tomcat server error

 
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've configured my computer for the jakarta-tomcat-3.2.1. I've changed the classpath so my jdk can find the servlet and jsp class files. I went in and changed the JAVA_HOME to equal the path to my jdk ( eg. set JAVA_HOME = C:\jdk1.3 ), I changed the port in the server.xml to 80 instead of 8080. I changed the initial memory in DOS up to 2816. So when I start up the server, the window says (verbatim):
out of environment space
out of environment space
out of environment space
unable to determine the value of TOMCAT_HOME

Does anybody know what this is about. I'm running windows 98. The classpath seems to work but nothing else.
 
Ranch Hand
Posts: 2166
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
To quote http://www.webappcabaret.com/javachina/tomcathowto.htm from Roseanne Zhang.
(very practical guidelines)

1. Unzip jakarta-tomcat.zip into c:\ rename c:\jakarta-tomcat to c:\tomcat
Try to avoid long names like c:\Program Files\Apache Group\jakarta-tomcat
You will have some troubles if your OS is win98 or win2000. It will be perfect fine on winNT. Please ask Mr. Bill Gates why.
2. Set TOMCAT_HOME=C:\tomcat
3. For win98, you may need to enlarge the environmental mem settings of MS-DOS. Change that setting from the MS-DOS Prompt "Properties" dialog - "memory" tab, initial environment setting. Using 3072 or above.
4. Set JAVA_HOME=D:\jdk1.2.2. or jdk1.3 or ..., wherever you install your jdk.
If you have jsdk installed before, uninstall it, or make sure the jar file is not on your CLASSPATH.
In every case you havent set the TOMCAT_HOME environment variable. With the environmental mem settings I have no experience, because I don't use DOS-clone type OS :roll:
hope it helps
Axel
[ January 05, 2002: Message edited by: Axel Janssen ]
 
mdotting
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the info, is it necessary for me to have a NIC card if I'm running this all as a local host?
 
Axel Janssen
Ranch Hand
Posts: 2166
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If NIC card is network card it is not necessary.
Put in the OS-install cd go to network section and choose Loopback controller.
Axel
 
mdotting
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
okay, so in startup.bat, tomcat.bat, tomcatEnv.bat I put in the first line:
set TOMCAT_HOME=C:\servlets_jsp\tomcat
still nothing, I'm getting the same exact error, very frustrating! Does it definitely go in the very first line because there's a bunch of commented code at first and there's also set echo on placed on the first lines of some of the files and I wasn't positive that my line would go before that. Do you think it has to do with my classpath? Sorry for my ignorance on this subject, I always have the hardest time installing and configuring things like this.
 
Axel Janssen
Ranch Hand
Posts: 2166
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by mdotting:
set TOMCAT_HOME=C:\servlets_jsp\tomcat


perhabs servlets_jsp is to long (see description above).
Normally people set the TOMCAT_HOME variable (and the JAVA_HOME) with Systemsteuerung/ (I dont know how its called in english Windows, but its where you deinstall software.) System-Icon. There extended section. Environment variables.
Hope it helps
Axel
 
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yup, in Win98, you have to use the SFN (Short file name) version of your path.

So: Which is why on that linked page above, Roseanne mentioned that Win98 users would have trouble with long folder names and spaces. Also, this command should go in your autoexec.bat, so you won't need to put it in all the other ones.

Also remember, you need to set JAVA_HOME to point to your JDK. Last I looked, Tomcat required a JDK installed so that it could compile the JSP's into servlets.

'@ECHO OFF' just means that the batch file will run without echoing every command to the DOS window, so it doesn't matter where you put your SET commands (before or after the ECHO command)
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!