• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Rob Spoor
  • Henry Wong
  • Liutauras Vilda
Saloon Keepers:
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh
  • Jj Roberts

Problem with Tomcat 4.0, can't see Tomcat Welcome Page.. pls helllpppp!!

 
Ranch Hand
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I've installed tomcat 4.0 using windows 2000. When I execute the startup.bat it says:
starting service Tomcat-Standalone
apache tomcat/4.0
Starting service Tomcat-apache
apache tomcat/4.0
everything seems to be working ok, but when I type in my browser http://localhost:8080/ it says:
ERROR
The requested URL could not be retrieved
While trying to retrieve the URL: /
The following error was encountered:
Invalid URL
I've modified the server.xml file so the port number will be 8080... so i don't think the port number is the problem.
any suggestions, ideas??
thanks..
 
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
What modification to server.xml? 'The port' should have been 8080 to start with.
 
Andres Gonzalez
Ranch Hand
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks for the response. I was reading a tutorial on how to set up tomcat and it explained that you could change the port number from 8080 to 80, so you didn't have to type 8080 everytime you were going to request an URL. I tried it and didn't work, so I changed it back to 8080.
you can find the tutorial here:
http://javaboutique.internet.com/tutorials/Tomcat/configure.html
but.. why is this error page coming up? any ideas or suggestions? do you have any other tutorial that explains how to install it?
thanks
 
Ranch Hand
Posts: 732
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
this is a good start up lesson for tomcat.
i used it myself when i began and had no problems.
try it:
here!
 
Andres Gonzalez
Ranch Hand
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Welll, lucky you .. I still have the same problem.
There's one thing: I'm on a LAN, behind a proxy. To be more precise at university. So, when I type http://localhost it shows:
ERROR
The requested URL could not be retrieved
--------------------------------------------------------------------------------
While trying to retrieve the URL: http://localhost.bond.edu.au/
The following error was encountered:
Connection Failed
it says localhost.bond.edu.au, don't know why...
I've also changed the proxy settings, where it says:
"Do not use proxy server for addresses beginning with:"
and I typed http://localhost
but it still don't work!!!
 
Saloon Keeper
Posts: 23409
159
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Try "Addresses beginning with" set to "127".
Localhost is the symbolic name for IP address 127.0.0.1
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Also, if you are using IE, turn off the 'friendly error messages', they sometimes make it hard to diagnose problems. (Tools | Internet Options | Advanced - Show friendly HTTP error messages , and make sure it's unchecked.)
 
Ranch Hand
Posts: 42
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
In you addressbar type http://127.0.0.1:8080/ In this way, you browser will not search DNS server to resolve the domain name.
 
Andres Gonzalez
Ranch Hand
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
grrrrr.... I should have a linux machine.. but I still get the same error. Now when I type http://127.0.0.1:8080/
I get the following:
ERROR
The requested URL could not be retrieved
--------------------------------------------------------------------------------
While trying to retrieve the URL: /
The following error was encountered:
Invalid URL
Some aspect of the requested URL is incorrect. Possible problems:
Missing or incorrect access protocol (should be `http://'' or similar)
Missing hostname
Illegal double-escape in the URL-Path
Illegal character in hostname; underscores are not allowed
Your cache administrator is webmaster.

.. One last question:
1o. ) If my directory tree is something like this:
local disk (c
- tomcat
- jakarta-tomcat-4.0
bin
classes
.
.
.
I set up in the environment variables:
CATALINA_HOME: C:\tomcat\jakarta-tomcat-4.0
TOMCAT_HOME: C:\tomcat\jakarta-tomcat-4.0
is this correct? If it is then I don't know what the heck is happening. I might reinstall again
thanks guy in advance for your cooperation
 
Andres Gonzalez
Ranch Hand
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
sorry, I screwed up my directory tree
my directory tree is c:\tomcat\jakarta-tomcat-4.0
thanks
 
Andres Gonzalez
Ranch Hand
Posts: 1561
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
GOT IT!!! THE MOST BEAUTIFUL CAT IS SHOWING IN MY BROWSER !!!
THE solution :
1o. ) I deleted all the tomcat directory, downloaded it again, follow all the setps and ran it. It still didn't work.
2o. ) If I'm using Forte for Java, OpenJMS (open source implementation of Java Messaging Service), tomcat; Why in the heck do I have to use a browser like MICROSOFT INTERNET EXPLORER!!!??? So, i followed my instincts and downloaded OPERA 6.0 for free.
and guess what... yep it worked !!
thank you guys for your support during these days, I really appreciated it.
PS: and If you haven't tried it yet, it's never late.
http://www.opera.com/download/
 
The airline is called "Virgin"? Don't you want a plane to go all the way? This tiny ad will go all the way:
SKIP - a book about connecting industrious people with elderly land owners
https://coderanch.com/t/skip-book
reply
    Bookmark Topic Watch Topic
  • New Topic