• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Apache windows 98 and Mediacom

 
Dean Reedy
Ranch Hand
Posts: 89
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have installed apache webserver on my windows 98 machine. Note: This is just for playing and not a production machine.
The problem I am having is that it installed great, no errors, and I start apache and type
htt://localhost/ and my default webpage displays fine.
But if anyone trys to connect to my website: They get nothing, server not found....
I had them try
http://my ip/Index.html
and
http://my computer Name.mchsi.com/Index.html
The second example shows that I am on the new mediacom network(Old Att broadband using excite before).
Any ideas, I did install the apache 1.3.23 version for windows.
Thanks,
Dean
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is your ISP blocking ports? (to prevent you from doing exactly what you're trying to do?)
 
Tim Holloway
Saloon Keeper
Pie
Posts: 18281
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ATT has probably firewalled you. Most consumer broadband account licenses don't allow you to act as a host, but until "Code Red" ran amok on the Internet lat year it was a legal issue not a technical one. After "Code Red" they reconfigured their firewalls to block inbound tcp/ip port 80 and other potential infection points.
 
Dean Reedy
Ranch Hand
Posts: 89
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is there a way to reconfigure Apache to run an another port? What other options do I have? ANy?
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You are probably out of luck. Most ISPs take the 'block everything, except what is needed' approach to security (or at least, now they do).

One thing you *could* try is going to grc.com and seeing what ports his site manages to sniff out on your PC. Most of them are reserved for something else of course, but this would tell you at least something about your ISP's security/port blocking policies. Failing that, just ask them.
 
Dean Reedy
Ranch Hand
Posts: 89
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well everyone, I finally got apache to work. I had to uninstall apache, and then reinstall to my c:\ directory, previously I went to the default directory apache recommends c:\Program Files\Apache Group\. I don't know if installing it to just c:\ helped or just the reinstall. Thankyou everyone for your help.
Dean
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic