Win a copy of The Career Toolkit this week in the Jobs Discussion forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Bear Bibeault
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Jj Roberts
  • Carey Brown
Bartenders:
  • salvin francis
  • Frits Walraven
  • Piet Souris

Tomcat with Windows 98 installation issue

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have Java 2.0 installed in "c:\java" directory
I have Tomcat 4.0 installed in "c:\jakarta-tomcat-4.0" directory.
I modified c:\autoexec.bat to include the foll line :
SET JAVA_HOME = C:\JAVA
I modified catalina.bat to set CATALINA_HOME to
c:\jakarta-tomcat-4.0.
Now, when I try to start the server via the startup script, it gives me the foll message:
Using Catalina_Base: c:\jakarta-tomcat-4.0
Using Catalina_Home: c:\jakarta-tomcat-4.0
Using Catalina_TmpDir: c:\jakarta-tomcat-4.0\temp
Using Java_Home: c:\java
Then immediately, another MS-DOS window pops up listing a huge number of lines of java code begining with:
java.lang.reflect.InvocationTargetException:java.lang.NoClassDefFoundError:javax naming/Naming Exception
Before I can read the rest, the window closes....
Can anyone advise me on how to get the Tomcat started?
 
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
put the CATALINA_HOME in autoexec.bat as well. The one startup.bat file calls a second file, and CATALINA_HOME won't be set in this one.

to make the window stay open, open a DOS window first, and run the script from the command prompt (not the shortcut)
 
GD
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!Mike,
Thanks for responding. I included the command
"SET CATALINA_HOME = C:\JAKARTA-TOMCAT-4.0" in my c:\autoexec.bat file.
Restarted my PC and tried to startup the server from the dos prompt. It gave the foll. message:
Out of environment space
Cannot find
This file is needed to run this program
I did check the startup and shutdown files. Their initial environment memory is set to 4096, so shouldn't cause any memory/space problems...
 
Ranch Hand
Posts: 18944
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
GD,
Sadly, your name does not meet the requirements of JavaRanch's naming policy. Please choose a name that does.
[ May 10, 2002: Message edited by: Bodie Minster ]
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I too got the same problem.. can any one tell me how to solve this problem?
thanks,
Satish
 
Author and all-around good cowpoke
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ah yesssss - a very annoying thing about Win98 - it does not give you enough memory space in the MSDOS console for environment variables that Tomcat wants to create. Unfortunatly I don't have a Win98 running, but as I recall, you need to change a setting that you can get to by right-clicking in the upper left corner of a console window and going to the properties dialog. Increase the environment memory space to something like 8K - if I recall correctly.
Bill
 
Would anybody like some fudge? I made it an hour ago. And it goes well with a tiny ad ...
the value of filler advertising in 2020
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic